Results 1 to 2 of 2

Thread: Washer munching

  1. #1

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605

    Washer munching

    IN THE LAST WEEK OR SO I HAVE RIDDEN WITH ALL MY SIGNATURE EXCEPT I CHANGED THE RUDE1 FOR A BRAND NEW X CHARGER.I CHECKED THE SLIP BEFORE I WENT OUT AND IT WAS 10FTLB DEAD.........NOW AFTER 3HRS OF RIDEING HARD,WAVE JUMPING,DOUGHNUTS,FLAT RUNS,@8580RPM....I REMOVED THE X CHARGER,TO CHECK THE SLIP....IT SLIPS AT...JUST AND I MEAN JUST OVER 8FTLB....I REMOVED THE WASHERS AND THEY SHOW SIGNS OF WEAR...ITS VISABLE....THESE ARE THE OEM WASHERS........NEEDLESS TO SAY THAT IM GONA REPLACE THEM WITH RIVAS BEFORE IT SEES ANY MORE ACTION.....BUT IS THIS NORMAL...IM AMAZED HOW GOOD THE OEMs STAND UP


  2. #2
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Throw some mcmaster spring washers on it too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pics of Les's B Impeller and Washers
    By Red Devil in forum 4-Tec Performance
    Replies: 52
    Last Post: 03-20-2006, 09:25 PM
  2. 6 spring washers on the clutch!!!
    By Green Hulk in forum 4-Tec Performance
    Replies: 18
    Last Post: 02-10-2006, 06:13 PM
  3. SC Ceramic Washer Failure Update
    By Jarrett in forum 4-Tec Performance
    Replies: 17
    Last Post: 11-08-2005, 08:59 PM
  4. Did your engine eat ceramic clutch washers?
    By Green Hulk in forum 4-Tec Performance
    Replies: 41
    Last Post: 07-18-2005, 10:26 PM
  5. SC Ceramic Washer Failure
    By Jarrett in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-14-2005, 07:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •