Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Steering problems with IS

    Anyone having steering problems with the IS especially in chop. My GTX handlebars does not want to stay even with dash when going straight ahead. I have to basically have the handlebars turned left to stay straight. Had steering adjusted 3 times at dealership. This problem is all the time even in slight chop.


  2. #2

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Sounds like steering adjustment, set the steering straight and check your steering nozzle (At the pump) to see if it's staright.

  3. #3
    No already a problem Please tell me it handles in chop good right right?!?

  4. #4

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Quote Originally Posted by kawidooguy780 View Post
    No already a problem Please tell me it handles in chop good right right?!?
    I don't think it's a problem, sounds like a poor ass excuse of a PDI to me.

  5. #5
    Oh well how are you liking your RXT iS so far?

  6. #6
    already been at dealer 3 times I need other IS owners to answer this Question thanx.

  7. #7
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Doubt there are enough iS owners out there to answer your question.

  8. #8
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Maybe your dealer is an idiot.... check the alignment yourself and be sure its strait.

  9. #9
    Turbo Doo's from Down Under one1one's Avatar
    Join Date
    Aug 2007
    Location
    Gold Coast, Australia
    Posts
    394
    It will be an alignment issue. Having had the floating deck of a S2 iS last week to do the cosmetic updates I can see how a dealer could get it wrong.

  10. #10

    Join Date
    May 2009
    Location
    Sacramento, CA
    Posts
    22
    My RXT iS runs straight and true....
    Although, I noticed current and wind can fool you into thinking it is not tracking correctly.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is anyone else having a problem with the search feature?
    By outonalimb in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-05-2010, 02:25 PM
  2. Has any one had any problems with the RXT IS
    By jumbojet in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-01-2010, 08:12 AM
  3. Replies: 2
    Last Post: 07-20-2009, 07:14 PM
  4. Replies: 10
    Last Post: 11-11-2006, 03:26 PM
  5. R & D emails is there a problem with mail server
    By Johnjet in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 01-19-2006, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •