Results 1 to 6 of 6
  1. #1

    UMI questions, need help!

    you guys that have installed the UMI steering in the GPR, do you remember if the bottom bearing was flush with the bottom of the tube/stalk?

    look at this one, bearing sticks down a bit, if I tighten the nylok nut to secure the steering arm tight, it puts way to much pressure on the "top" bearing...

    when I first started to assemble this, the stem would not slide in, just up to the larger ID area. I found the top bearing to be crooked right out of the box...

    after using suitable tool, I tapped the bearing to square into the bore, now the stem fit nicely. but the shouldered area where the arms goes does not protrude past the bearing, if I tighten the nut to much it will stress the top bearing. the top bearing is already not smooth rolling right out of the box, any thoughts?

    I have this unit already sealed and bolted down...
    I don`t remember how the UMI was in the GTX, I`m pretty sure I didn`t have any over tighten or cocked bearing issues... Thanks...


  2. #2

    pics

    pics:
    Last edited by Pale Rider; 01-19-2010 at 05:24 PM.

  3. #3
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I haven't done the gpr but on my GP the bottom bearing was flush looks just like the tube you have.

  4. #4
    Quote Originally Posted by OsideBill View Post
    I haven't done the gpr but on my GP the bottom bearing was flush looks just like the tube you have.
    hmmm, the bottom bearing is not flush here. the top bearing was cattywampus, but easy to seat...

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    My UMI on the GPR the lower bearing is not flush hangs down aprox 1/16" All is good with my set-up. Searing is good with no binding.

  6. #6
    Quote Originally Posted by beerdart View Post
    My UMI on the GPR the lower bearing is not flush hangs down aprox 1/16" All is good with my set-up. Searing is good with no binding.
    ok, cool that explains why it is why it is...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pump rebuild question... Need help, I'm stuck!
    By DKFox in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-07-2009, 02:11 PM
  2. '02 Virage 800i fuel injection questions... need HELP!
    By ProXR 440 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-17-2009, 01:07 PM
  3. speed questions????? need help please!
    By 1fastrat in forum 2-Stroke Performance
    Replies: 18
    Last Post: 08-25-2008, 11:07 AM
  4. Quick Question- need help RXT-X
    By Bigcat1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-25-2008, 04:17 PM
  5. Riva IC questions (need help)
    By gotpurp305 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-11-2006, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •