Results 1 to 3 of 3
  1. #1

    Join Date
    Mar 2009
    Location
    San Diego, Ca
    Posts
    1

    Crapping out at 1/3 throttle

    I've always wanted a jet ski and so when an SL780 popped up on Craigslist for $650 I jumped on it after convincing the wifey.

    Well, today (2 mos. later), I fixed the starter switch, got the thing to start, got the MFD back to life and the bilge pump (thanks to months of lurking on here), and downloaded all the shop manuals a troubleshooting guides.

    So, it runs fairly smooth at low speeds, I'd say up until about 25 mph. Once it gets to about 1/3 throttle it loses speed and vibrates and has kind of a knocking sound almost like the cylinders are trying to fire. I know it's not in limp mode because I disconnected the gray wire for a run and it did the same thing. Is there a magic rpm where the high fuel mixture kicks in?

    I am a poor grad student with three kids trying to get by, so I am trying to be as efficient as possible with the fix. Any ideas? Rebuild the carbs? Check compression? Any help would be greatly appreciated.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by mikoyle View Post
    I've always wanted a jet ski and so when an SL780 popped up on Craigslist for $650 I jumped on it after convincing the wifey.

    Well, today (2 mos. later), I fixed the starter switch, got the thing to start, got the MFD back to life and the bilge pump (thanks to months of lurking on here), and downloaded all the shop manuals a troubleshooting guides.

    So, it runs fairly smooth at low speeds, I'd say up until about 25 mph. Once it gets to about 1/3 throttle it loses speed and vibrates and has kind of a knocking sound almost like the cylinders are trying to fire. I know it's not in limp mode because I disconnected the gray wire for a run and it did the same thing. Is there a magic rpm where the high fuel mixture kicks in?

    I am a poor grad student with three kids trying to get by, so I am trying to be as efficient as possible with the fix. Any ideas? Rebuild the carbs? Check compression? Any help would be greatly appreciated.
    Welcome to the Hulk.
    You have been lurking for a while....

    Your suggestions were the first thing that came to mind.

    Compression test and clean the carbs.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Other things to try;

    Trim the spark plug wires 1/4" and re-attach spark plug caps

    Make sure you have the correct spark plugs installed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 700 intermittantly stalls out at full throttle????
    By StanSutton in forum Polaris Open Discussion
    Replies: 9
    Last Post: 05-20-2013, 08:30 PM
  2. GP1200r runs but bogs out at 1/2-3/4 throttle only
    By bmkelly75 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 11-21-2012, 11:59 PM
  3. sl750 dies out when hitting the throttle at idle
    By polarisman in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-11-2011, 11:43 AM
  4. twin seadoo 110 hp engines are flooding out at quarter throttle
    By jetskijason in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-22-2011, 08:41 AM
  5. 1997 Polaris 780 SLT (Cutting out at full throttle)
    By harleyfun1996 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-24-2008, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •