Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Steering issue

  1. #1

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201

    Steering issue

    I just installed the 1 degree wedge. Once I put everything back together, I noticed that it will now only turn halfway to the left, but right has full range. When adjusting the steering, I only rotated the adjuster 1.5 turns to have it line up with the handlebars. Did I miss something?

    Also, is the play in the sterring column normal? It has more give than I would like...but that may be normal.

    Thanks!


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    1.undo the the steering cable bolt on the right side of the pump nozzle,
    2. set pump nozzle in centre of cavity use a ruler/set square/tape measure.
    3. set handlebars straight ahead .
    4. loosen adjusting nut on end of cable and unscrew fitting until bolt and the hole on the nozzle line up. (do not bump nozzle or handlebars).
    5. tighten bolt into nozzle and tighten adjusting nut.

    that should do it.

  3. #3

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201
    Sorry, maybe I wasnt clear enough. I did do that. The problem I ran into was when it was back together, I can only turn the handle bars about half as far as they should go to the left, but when I turn it to the right I have full range. The nozzle and bars are lined up perfect.

    Nothing is hitting that I can see.

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    doesn't sound right if you only went 1 1/2 turns on adjuster. you have to basically screw the adjuster out the thickness of the wedge which i'm sure is more than 1 1/2 turns. so what you are saying nozzle hits stops before handlebars reach their stops? or vise versa. all else fails check cable retainers both ends and check handlebar end for further adjustment. will be something very simple if it was ok before you started.

  5. #5
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,161
    +1
    600
    Quote Originally Posted by BC18471 View Post
    I just installed the 1 degree wedge. Once I put everything back together, I noticed that it will now only turn halfway to the left, but right has full range. When adjusting the steering, I only rotated the adjuster 1.5 turns to have it line up with the handlebars. Did I miss something?

    Also, is the play in the sterring column normal? It has more give than I would like...but that may be normal.

    Thanks!

    MAN this is bad you are going to need a new engine , it all fucked now

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by sirbreaksalot View Post
    MAN this is bad you are going to need a new engine , it all fucked now
    you are a funny funny man maybe he should just sell it and buy a 250lx as its already fitted from the factory

  7. #7
    Is the nozzle supposed to have a little side to side play before it actually pulls on the steering wheel? My nozzle will play about a mm or 2 before is pulls on the steering cable, and I can't remember if it has always done this or not.

  8. #8

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201
    I dont like your attitudes. I am selling this and buying a sea doo.

  9. #9
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    sell me the motor then. 20 bucks, you ship. unclip the steering linkage from the nozzle and see if you can turn the bars all the way, if you can then you know its the nozzle, if you cant then its in the bars or it might be a bent linkage.



    Sean

  10. #10

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201
    Quote Originally Posted by smokeysevin View Post
    sell me the motor then. 20 bucks, you ship. unclip the steering linkage from the nozzle and see if you can turn the bars all the way, if you can then you know its the nozzle, if you cant then its in the bars or it might be a bent linkage.



    Sean

    Hah. Ok. I will give that a shot.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering Issue--1999 XL1200 ltd
    By rollingtide1 in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 08-28-2010, 01:12 PM
  2. Replies: 1
    Last Post: 08-18-2010, 04:28 PM
  3. Hard Steering issue with 260x
    By GEKKON4 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 22
    Last Post: 05-24-2010, 10:18 PM
  4. Help - Non-responsive '03 SC Steering Issue ...
    By GTXDawg in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-28-2008, 08:48 PM
  5. RXT Steering Issue
    By wiki711 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-16-2006, 06:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •