Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311

    new mods now low RPM miss

    I took my RXT-X out yesterday for the first time after several mods and I need some input here is what I have added

    1- manifold upgrade kit
    2- intercooler relocation kit plus graco strainer
    3- Riva water box Thru hull exhaust
    4- removed OPAS ( using block off plates till the RE`s come in )
    5- installed 50lb injectors with fuel controller
    6- B-Kit I ran these items on my 05 RXT with no issues
    7- boost gauge
    8- drilled and tapped exhaust manifold for the O2 sensor
    9- installed air/fuel gauge with new O2 sensor
    10- reduction nozzle with 82MM ring (I did not like as I think it was a dog out of the hole and cavitated)
    11- re-pitched 15/22

    the ski runs rough until about 5000 RPM it just does not wont to run at below 5000 at WOT air/fuel at 12.2-12.4 air temp was around 75, I am just not sure where to start I may disconnect the fuel controller and test again as maybe there is a conflick between the controller and the X ECU again this set up ran great on my 05, could I have a air leak where I took off the intake manifold but I would think it would miss at WOT. I am running the same plugs but again I would think it would miss at WOT
    what do you guys thin


  2. #2
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    How much boost are you making?

    This will be a good sign if you have a air leak.

    Have you tired putting the stock injectors back in and see if it misses then. It might be running waaay to rich at idle, etc.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by shhr View Post
    I took my RXT-X out yesterday for the first time after several mods and I need some input here is what I have added

    1- manifold upgrade kit
    2- intercooler relocation kit plus graco strainer
    3- Riva water box Thru hull exhaust
    4- removed OPAS ( using block off plates till the RE`s come in )
    5- installed 50lb injectors with fuel controller
    6- B-Kit I ran these items on my 05 RXT with no issues
    7- boost gauge
    8- drilled and tapped exhaust manifold for the O2 sensor
    9- installed air/fuel gauge with new O2 sensor
    10- reduction nozzle with 82MM ring (I did not like as I think it was a dog out of the hole and cavitated)
    11- re-pitched 15/22

    the ski runs rough until about 5000 RPM it just does not wont to run at below 5000 at WOT air/fuel at 12.2-12.4 air temp was around 75, I am just not sure where to start I may disconnect the fuel controller and test again as maybe there is a conflick between the controller and the X ECU again this set up ran great on my 05, could I have a air leak where I took off the intake manifold but I would think it would miss at WOT. I am running the same plugs but again I would think it would miss at WOT
    what do you guys thin
    I'm gonna guess you have a bad injector, coil, or fouled plug. Also you should check compression on all cylinders just to eliminate a leaky valve or something of that nature. Try pulling the coils 1 at a time and see wich one does'nt make a difference. This will tell you wich cylinder is missing.

  4. #4
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    my boost numbers were around 11.5 at 8060 water was rough so it was hard to really watch the numbers at WOT.

    I will check the plugs next time out by pulling the coil one at a time

    I have though about putting the stock injectors back in but I am not sure how they would work with the fuel controller as it was set up to run with 50`s

  5. #5
    dduck dduck1628's Avatar
    Join Date
    Apr 2007
    Location
    St Augustine FL
    Posts
    623
    Check you coils. See if one is cracked on the side. Coil may arc through the crack. My 07 RXP did the same thing. Idled find and misfired all the way to around 5000RPM when accelerating.

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Whats your AFR at idle? X ecu is different then a 05 ecu. So everything is not the same or is it?

  7. #7
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    at idle my air/fuel was around 14.5-15

  8. #8
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Controllers are so 2007. I bet this is the problem. Get a rrfpr and see if this doesn't fix it.

  9. #9
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    I think I will unplug the controller and see if it smooths out, the ski was also a little hard to start so


    I hope it is the controller as I like the idea of the RRFPR I just wonder if I can go back to the stock injectors with the RRFPR

  10. #10
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    Yeah mate you are running waaaaay to rich down bottom. Fouling up up the plugs.

    Get rid of that controller and run a RRFPR.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Yamaha XL760 Low RPM Miss
    By shawnmd in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 03-09-2011, 01:52 PM
  2. New Mods...Now having problems!!
    By 01yamigpr1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 04-11-2010, 11:03 PM
  3. 2001 GTS low RPM miss
    By marcporter in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-17-2009, 09:14 PM
  4. 96-97 GTX low rpm miss
    By hotrod_sxty8 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-26-2008, 04:26 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •