Results 1 to 4 of 4
  1. #1

    Angry 2000 genisis ffi

    I just made a repair to one of my pistons. All went well and the engine started right up. I have a problem with my idle speed. it will not idle and trys to run at about halve throttle. I adjusted the cables, but with no responce. it is like they are getting a signal to open with out throttle movement.
    The guys at my local dealer dont have any thing good to say about this model.
    If anyone has any ideas, I could use the help


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Welcome!

    Click here for the Polaris Service Manuals.

    Unplug the TPS (Throttle Position Sensor), located at the rear end of the throttle body, under the flame arrestor cover.

    Start the engine. If it idles correctly with the TPS unplugged, replace the TPS sensor.

    Check that the throttle cable is working correctly, so that when the thumb lever is at rest, the throttle plates are actually closed.

    Also check that the TPS sensor has not been knocked out of position.

  3. #3

    THANKS

    hey, thanks for the advice. this morning i thought that maybe it was sucking air below the butterfly housing. when i disassembled the engine there were 3 or 4 gaskets stacked up. not sure why accept maybe it sucked air from the factory. i made new gaskets and i think it helped. we will be on the water next weekend anyway.

    thanks.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by mudgobbler View Post
    ...when i disassembled the engine there were 3 or 4 gaskets stacked up.
    not sure why except maybe it sucked air from the factory.

    I made new gaskets and I think it helped. we will be on the water next weekend anyway...
    Which gaskets are you referring to?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	5578%5C5578c004.gif 
Views:	40 
Size:	58.9 KB 
ID:	132098   Click image for larger version. 

Name:	5578%5C5578c005.gif 
Views:	41 
Size:	68.3 KB 
ID:	132099  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Genesis FFI Leaky Fuel Injector
    By MarcT in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-23-2009, 10:42 AM
  2. 2000 genesis ffi
    By drwebb69 in forum Polaris How To & FAQs
    Replies: 44
    Last Post: 08-24-2008, 08:24 PM
  3. W/T/B Compartment door 2000 genisis carb
    By RiverRat19405 in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-05-2008, 06:30 AM
  4. 2000 genesis ffi
    By drwebb69 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 05-31-2008, 12:49 PM
  5. 2000 Genesis FFI questions
    By havasufun in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-10-2007, 06:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •