Results 1 to 6 of 6

Thread: '99 Ultra 150

  1. #1

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144

    '99 Ultra 150

    Me again,

    My new used ultra 150 has a HIN above 41804 which is supposed to be when the update CDI started going into these ski's. The PO has the cheaper plugs in the ski which would match the updated CDI.

    Can any one verify this?

    Thanks


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,012
    +1
    283
    Assuming the CDI box hasn't been changed, that is correct.

  3. #3

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    I did a compression check and the mag cycl was 119.5, center is 119.5 and the pto is 120. compression gauge is not calibrated but they were pretty even. The motor is stock with 67.5 hours.

    I looked at the pump, bearings and impeller which look good.

    The oil lines are attached and look fine, but how can you test to see if the oil injection is working? I can bearly see the oil level through the tank, so it would be hard to run a tank of premix and mark the oil tank level to see if it drops at the end of the full tank. I does smoke when running on the hose.

    Thanks for the help so far.

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Those oil lines are prone to crack so keep an eye on them. Alot of us have been changing them out with tygon line. More info here.

    http://www.ultra150.yuku.com/topic/3036

  5. #5

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    Thanks, I switch out mine this week. How do you get at the bottom two bolts on the flame arrester? Any tips, thanks.

  6. #6
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    LoL you dont. Take the 2 bolts out that hold the f/a to the exhaust chamber then grab it from each end and rock it back and forth while pulling up on it. It should pop rite off. if it doesnt there are 2 clamps underneath on the #1 and #3 carb loosen them up a bit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need a jetpump for a 99 Ultra 150
    By mirefire in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 03-13-2008, 08:10 PM
  2. 99 ultra 150 CDI.. now where do I get the NGK R6918C-9 spark plugs?
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 02-25-2008, 11:41 PM
  3. 99 Ultra 150 won't start
    By wareameye in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 09-24-2007, 06:48 AM
  4. 99 Ultra 150 Pump bearing replacement
    By gilson in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-09-2007, 01:59 PM
  5. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •