Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Join Date
    Jun 2006
    Location
    chicago area
    Posts
    10

    Gp1200r SUCKS, In the shop again and I am being screwed

    hey everyone, This is my first post here, RX951 pointed me here and I am hoping to get a little help.

    My gpr is in the shop again. Third time this year.
    Pulling 6700 rpms. Has a cooling problem too, where the pressure build up is too high and pops off the hose clamp. GOD I WISH I NEVER HAD IT MODDED. It has stinger exhaust, riva heads not the interchangable ones, freeflow, handling kit, speedfreaks nujet prop, mostly all I can think of off hand. Just got off the phone with the mechanic and said that going to look why pressure is so high with cooling, but to figure out why the rpms are low would have to take off the carbs, $$$$$$$$$. I have put well over 12000 into having the boat fixed since I have had it. At one time, two cylinders heads, exhaust a bunch of **** went, and a lot of this stuff going back every two weeks for 200 to 500 in repair. I think I am getting ripped, all I get for a response is that they are setting the boat up to rivas specs.

    I would like to know if anyone has any ideas, The pvs, I told are opening all the way, I would like to go back to my d-plate, but when they rebuilt the motor they put the wrong head on the second cylinder and it does not have the mount for the oem exhaust. Please can anyone figure out something on this thing. Also what do you think she is worth? If you have a head that will fit please let me know. I have dumped so much money into the boat, and I have yet to ride it going over 65 mph. PLEASE help


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum neillauer

  3. #3
    Crash Test Dummy Smitty's Avatar
    Join Date
    Jun 2006
    Location
    Cullman, AL
    Posts
    1,280
    +1
    2
    Get a stock head to go on it..... you can have it milled later, or even buy one that is already milled.

    I've got the Stinger on my ski, it works fine.... .what cooling hose is popping off?

  4. #4

    Join Date
    Jun 2006
    Location
    chicago area
    Posts
    10
    the boot that connects the stinger 3 to the first half of the exhaust, the clamp on the front side is popping off. thanks for the welcome as well

  5. #5

    Join Date
    Jun 2006
    Location
    chicago area
    Posts
    10
    why the stock heads?

  6. #6
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Take the stinger off. Take off the coupler. Clean it with Windex. Clean the front pipe with windex. Reassemble.

  7. #7
    subarupartsdude's Avatar
    Join Date
    Jun 2006
    Location
    Norfolk,Va
    Posts
    591
    Quote Originally Posted by neillauer
    the boot that connects the stinger 3 to the first half of the exhaust, the clamp on the front side is popping off. thanks for the welcome as well
    Listen to what Mark aka Hydrotoys told ya.
    Are you dumping any water overboard?

  8. #8

    Join Date
    Jun 2006
    Location
    chicago area
    Posts
    10
    yea there is an extra two dumps out of the back of the boat, dont know much about them, just that I didnt put them there the mechanic did. It is currently at the shop and he is telling me it shouldnt build that much pressure and it most have a clog in the line somewhere.

  9. #9
    Crash Test Dummy Smitty's Avatar
    Join Date
    Jun 2006
    Location
    Cullman, AL
    Posts
    1,280
    +1
    2
    If you want to put the stock exhaust back on, you can go with a stock head.

    Do the windex thing, like Mark said. Go to Lowes, get new clamps. Make sure there is nothing stuck down in your exhaust anywhere, pull the rest of the stinger all the way to the waterbox and shake it, then shake the waterbox. You can do a jetworks mod with the stinger, too.

  10. #10

    Join Date
    Jun 2006
    Location
    chicago area
    Posts
    10
    Dont the riva heads give me a lot of performance? THe stock exhaust with the d-plate on will i run into carb problems?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in the pump cone and bearings...now what???
    By RXP-REX in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-23-2007, 07:36 PM
  2. Back in the water again!
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 04-29-2007, 12:52 PM
  3. Ski in the shop
    By brad2510 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 03-24-2006, 10:06 PM
  4. Getting RXP back tomorrow after down time in the shop.
    By Jrsrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-14-2005, 09:46 AM
  5. RXP still in the shop
    By Jrsrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-10-2005, 09:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •