Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    What would life be without a PWC?........ goBENGALS's Avatar
    Join Date
    Apr 2007
    Location
    Clearwater, FL
    Posts
    103

    Need help!! 785 start issues....what a surprise

    Alright my boat (the 9 just caught "swine flu" and I don't know what in the world is wrong.

    1) Fuel is on, key is in, the boat fires right up and will rev for about 5 seconds then just dies.
    2) Tried firing it up and giving it throttle and it gets about 1/4 throttle(guessing) and just cuts out as well.

    Any ideas? I'm stumped and I built this thing from the ground up!


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    do you have a spark testor to put on it to see if the spark is going away

  3. #3
    What would life be without a PWC?........ goBENGALS's Avatar
    Join Date
    Apr 2007
    Location
    Clearwater, FL
    Posts
    103
    I don't have a spark plug tester, but if you think thats a good place to start then I'll order one or go buy one if they sell them at an auto parts store. Advice?

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by goBENGALS View Post
    I don't have a spark plug tester, but if you think thats a good place to start then I'll order one or go buy one if they sell them at an auto parts store. Advice?

    Yeah any auto parts store will have them .

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Make sure the fuel switch isn't plugged up from sitting also pull the from the carbs to the switch and see if you can blow through it ,you should hear it bubbling in the tank .

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    I'm thinking fuel related.

    Try pouring some premix down the carb throats after you get it started. If it keeps running, you have a fuel supply problem.


    CAUTION: a backfire can lead to a fire. Have an extinguisher handy when doing this.

  7. #7

    Join Date
    Oct 2008
    Location
    Lake havasu city
    Posts
    318

    I agree

    He had some fuel line location problems some low life tried to steal his fuel lines and siphoned his gas.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by chopper901 View Post
    He had some fuel line location problems some low life tried to steal his fuel lines and siphoned his gas.
    For REAL??????

    Man, times is tough when you can't afford $1 a ft fuel hose......

  9. #9
    What would life be without a PWC?........ goBENGALS's Avatar
    Join Date
    Apr 2007
    Location
    Clearwater, FL
    Posts
    103
    yea your telling me. I would have given the @$$hole 20 bucks for gas as opposed to messing with my ski!

    I'll try the hose being plugged at the switch bc it doesn't seem like there is a difference in the problem when the fuel switch is on or off. I'll let you guys know the verdict later tonight.

  10. #10
    What would life be without a PWC?........ goBENGALS's Avatar
    Join Date
    Apr 2007
    Location
    Clearwater, FL
    Posts
    103
    alright well I tried a mixture of diagnostics to figure this problem out.

    1) I checked the on/off valve and it is fine no clogs at all.

    2) Tried blowing into the line from the carbs to the tank and it bubbles the fuel in the tank so no clogs there.

    3) Chopperjoe my stepbrother said just try a line from the tank to the carbs (bypassing the fuel/water seperator and the on/off) and he hit it on the head!

    The fuel pickup must be getting no power or it has failed because even when bypassing everything the boat dies after a few seconds.
    Is there a way to check power in the ebox for the fuel pickup?

    Sucks this all happened bc the economy is so bad someone had to resort to trying to rip a damn gas tank out of a jetski for 10 F***IN gallons of fuel....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 07-30-2007, 08:22 AM
  2. need help getting started
    By skootz in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 06-08-2007, 02:14 AM
  3. Need Help-- 785 Cdi In Sl750?
    By KEYZBUM in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-14-2007, 11:30 PM
  4. need help 785 domes ???s
    By 785 lugs in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-12-2006, 10:16 AM
  5. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •