Results 1 to 4 of 4
  1. #1

    loss of speed and noise near the back

    i have a 2005 rxt and i have lost around 17 miles. when i got it i could max out at 72 and now i cant go any faster than 56. take off is still pretty good and it doesnt feel like it is slipping. also when i put the garden hose to it, it has a grinding noise torward the back like a metal to metal grind. any suggestions?


  2. #2
    Welcome to the forum.

    Anthing in the pump...besides the prop?

    Have you checked your sc washers....assuming you haven't changed them yet?

  3. #3

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by Trc View Post
    i have a 2005 rxt and i have lost around 17 miles. when i got it i could max out at 72 and now i cant go any faster than 56. take off is still pretty good and it doesnt feel like it is slipping. also when i put the garden hose to it, it has a grinding noise torward the back like a metal to metal grind. any suggestions?
    check your pump bearings

  4. #4
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Nah his SC washers are gone. The noise is the normal sound the pump makes out of water but with him knowing something is wrong it is way more noticeable.

    Take the hose off the SC inlet and see if that wheel spins freely.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of speed and power. Help! 2011 FZS
    By Familycat in forum Yamaha PWC Performance (4-stroke)
    Replies: 24
    Last Post: 05-04-2014, 07:07 AM
  2. ***Update*** VX Deluxe loss of speed and some smoke
    By bassdocktor in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 11-14-2011, 09:26 PM
  3. RXP-X Loss of acceleration and top speed
    By laarben in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-31-2008, 03:15 PM
  4. Loss of speed and High Rpms
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-02-2006, 11:35 AM
  5. Loss of speed and RPMs
    By NJ-Ski in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-21-2006, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •