Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38

Thread: Back in Black!

  1. #1
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44

    Back in Black!

    Got the beastie fired up late this afternoon after a full weekend of wrenching. It's snorting and popping like it used to, and I can't wait to get it out on the water. The relocated CDI box and battery gives a ton of room in the back of the ski. Huge thanks to WFO for all his help.

    YOU LIKE????

    On the bench:





    In the ski:





  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    excellent! looks good dawg

  3. #3
    icedog10's Avatar
    Join Date
    Jun 2007
    Location
    Houston,Texas
    Posts
    446
    Looks good! When are we going to the water?????

  4. #4
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    beautiful!!

    i'm guessing that is just a Y fitting from the pump strainer that is going into cyl. 2&3??

  5. #5
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    looking Great! Wish I had this luck this weekend! Lee

  6. #6
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    Thanks Billy!

    Wade, not until this weekend. What the heck are we going to do about riding - it's Memorial Weekend and every idiot in the city is going to be there. Not sure how I'm going to break it in with that mess going on. By the way, my ski is now sporting your NOS kit. Sucker!

  7. #7
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    Quote Originally Posted by IowanGPR View Post
    beautiful!!

    i'm guessing that is just a Y fitting from the pump strainer that is going into cyl. 2&3??
    Nah - it's two hoses. They're just stacked on top of each other so it just looks like one hose.

  8. #8
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    i like the plug wires running a straight line from the box over top of the cyls.... sweet

  9. #9
    icedog10's Avatar
    Join Date
    Jun 2007
    Location
    Houston,Texas
    Posts
    446
    my ski is now sporting your NOS kit. Sucker!

    LOL!!! I'm glad WFO put something on there that will help make your Fat Azz FAST!!!

    Motor looks great.

    P.S.: I was thinking the one kit was to small for my 02 anyway!

  10. #10
    JetSkiDaddy's Avatar
    Join Date
    May 2005
    Location
    Houston, TX
    Posts
    1,418
    +1
    4
    Looks sharp bro

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Double Trouble---Back In Black!
    By jetskibrian in forum PWC Fishing
    Replies: 5
    Last Post: 05-06-2012, 07:38 AM
  2. Going back in history...........
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 11-21-2008, 10:47 AM
  3. Back in Action
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-10-2006, 09:29 PM
  4. Back in action
    By 01xdime in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-18-2006, 05:27 PM
  5. IMROS back in the goove!
    By Tube Master in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-09-2006, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •