Results 1 to 4 of 4
  1. #1

    2004 xlt problem

    I WENT OUT JUST CRUISING ALONG THE SKI JUST DIED WILL NOT START PULLED SEAT NOTICE A LOT OF WATER IN THE BOW ENGINE AND BATTERY DEPARTMENT CHECKED PLUGS THEY WERE SCREWED IN NEXT I PULLED SPARK PLUG THEY WERE WET TURNED OVER ENGINE WATER WOULD SHOOT OUT OF CYLINDERS NEED HELP HAS D-PLATE INSTALLED


  2. #2
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Quote Originally Posted by graham65 View Post
    I WENT OUT JUST CRUISING ALONG THE SKI JUST DIED WILL NOT START PULLED SEAT NOTICE A LOT OF WATER IN THE BOW ENGINE AND BATTERY DEPARTMENT CHECKED PLUGS THEY WERE SCREWED IN NEXT I PULLED SPARK PLUG THEY WERE WET TURNED OVER ENGINE WATER WOULD SHOOT OUT OF CYLINDERS NEED HELP HAS D-PLATE INSTALLED
    crank till all water is out, put some premix (40-1) in each cyl and try to start... MAKE SURE YOU GET THIS THING STARTED TODAY and run it long enough to get hot to dry the motor out

  3. #3
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    Sounds to me like your ski was not able to get the water out of the hull.

    Kept building up until your engine sucked water in through the intake.

    Check your bilge pumps if you've got them.

    EDIT:

    Looks like you've got a scavenge type system that is attached to the jet pump and works off of venturi.

    Check these hoses to make sure they are not blocked:





  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    The XLTs are bad about the drive shaft hose leaking water into the hull.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 xlt 1200 waverunner starter problem
    By hewi02 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-31-2013, 08:31 PM
  2. need help with another xlt problem
    By izik in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-26-2008, 01:12 PM
  3. 2004 rxp problem
    By baba850r in forum 4-Tec Performance
    Replies: 4
    Last Post: 02-14-2008, 08:15 PM
  4. 2004 RXT Problem
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 24
    Last Post: 10-15-2007, 09:56 PM
  5. Polaris MSX110 2004 "Multiple Problems"!
    By spkpolarismsx in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-19-2007, 06:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •