Results 1 to 10 of 10
  1. #1
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    Cavitation Issues

    I am still fighting with launch cavitation on the P-X. I put in a solid front mount and waiting on my scat seal to arrive this week. Can't figure out if its the carbon seal leaking air or the driveshaft moving around. But heres the weird thing, I just rebuilt an 06 RXP and its doing the same thing. I am installing the driveshaft incorrectly? I followed the service manual exact and have the tell tale mark in the right place. Do you guys have any tips?


  2. #2

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by Antiguan RXP View Post
    I am still fighting with launch cavitation on the P-X. I put in a solid front mount and waiting on my scat seal to arrive this week. Can't figure out if its the carbon seal leaking air or the driveshaft moving around. But heres the weird thing, I just rebuilt an 06 RXP and its doing the same thing. I am installing the driveshaft incorrectly? I followed the service manual exact and have the tell tale mark in the right place. Do you guys have any tips?
    put that seal in then let us know

  3. #3
    Live to RIDE. brendus's Avatar
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    326
    how does the bearing seal stop cavitation????

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by brendus View Post
    how does the bearing seal stop cavitation????
    With the accordian boot under hard acceleration it can be sucked away from the stainless top hat on the drive shaft and therefore introduce air from inside the hull to the tunnel causing cavitation. R88

  5. #5
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Question; when the floating ring and carbon seal are all assembled and the pump is out. Are you suppose to be able to pull the drive shaft outwards 1-2 inches? I can and there is a fair amount of pressure from the the floating ring compressing the belows. Is this normal?

  6. #6
    dduck dduck1628's Avatar
    Join Date
    Apr 2007
    Location
    St Augustine FL
    Posts
    623
    Does the P-X have fins in the pump shoe. I had part of one of the fins on my RXP break off. It cause mine to cavitate badly out of the hole.

  7. #7
    Quote Originally Posted by Antiguan RXP View Post
    I am still fighting with launch cavitation on the P-X. I put in a solid front mount and waiting on my scat seal to arrive this week. Can't figure out if its the carbon seal leaking air or the driveshaft moving around. But heres the weird thing, I just rebuilt an 06 RXP and its doing the same thing. I am installing the driveshaft incorrectly? I followed the service manual exact and have the tell tale mark in the right place. Do you guys have any tips?
    Get some wide zip-ties, like 3 of them, and zip them in place in the valley parts of the accordian boot, then slowly tighten them so the pressure forces the boot to expand. Not too much as too much pressure on the carbon ring will cause it to get too hot, but just enough pressure to keep them firmly in contact which each other.

  8. #8
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by novaprop67 View Post
    Get some wide zip-ties, like 3 of them, and zip them in place in the valley parts of the accordian boot, then slowly tighten them so the pressure forces the boot to expand. Not too much as too much pressure on the carbon ring will cause it to get too hot, but just enough pressure to keep them firmly in contact which each other.
    That's a great tip!!

  9. #9
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Thanks I will try that out and let you know if it fixes the problem.

  10. #10
    Duppy no who fi frighten, Make Dem Try Good2Go16's Avatar
    Join Date
    Mar 2009
    Location
    Grand Cayman, Cayman Islands
    Posts
    489
    Quote Originally Posted by Antiguan RXP View Post
    Question; when the floating ring and carbon seal are all assembled and the pump is out. Are you suppose to be able to pull the drive shaft outwards 1-2 inches? I can and there is a fair amount of pressure from the the floating ring compressing the belows. Is this normal?

    Yes you should be able to pull the pump outwards about 1" to 2" with the pump out.

    Check out this link it might help you out

    http://www.greenhulk.net/forums/showthread.php?t=90530

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cavitation Issue
    By Hockey369 in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 06-25-2008, 09:36 PM
  2. Prop Spin/Cavitation Issues Resolved.
    By ba6636 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-20-2008, 06:40 PM
  3. 96 XP cavitation issues after sharp turns
    By r4ma1r in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-28-2008, 06:29 PM
  4. Cavitation issues..Ultra 150
    By BrandonB in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 06-09-2007, 05:37 PM
  5. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •