Results 1 to 5 of 5
  1. #1

    Cool my 780 slt is taking on water

    I am new to this maybe stupid question I have a 1996 polaris 780 slt bought cheap during winter 1st time out this weekend everything working welll starts losing speed i look and bilge is going goto shore full of water appears to be pumping in from under plastic drive shaft guard any ideas to get in to it do i need to pull the jet any help would be appreciated
    thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome to the Hulk!

    Click here for the Polaris Service Manuals, and much more.

    Sounds like the through-hull bearing assembly needs to be rebuilt, or replaced. The seals and bearing are standard parts, available from a bearing shop.

    You should take the time to read up on your machine. It will save you a lot of potential trouble. The link above leads to much info.

    More can be found by reading and searching on these forums.

    You can also buy good used parts from a number of sources, including John Zigler (member on here).

    Running the engine without checking, cleaning or replacing various items can lead to sudden engine failure, with almost no warning.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Welcome to the Hulk Hawg.

    Pretty sure the SLT has a weak plastic piece that the through hull seal attaches to. I think there may even be a service bulletin about it.

    You may need to remove the back half of the jet pump and drive shaft. Then replace the plastic fitting and re-install.

    There's an on line manual for help posted in the tech section.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by xlint89 View Post
    ...Pretty sure the SLT has a weak plastic piece that the through hull seal attaches to. I think there may even be a service bulletin about it...
    Which item are you referring to?
    1996 SLT 780 shown


  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Bulletin PWC-94-04 Possible water leak on SLT drive shaft through-hull fitting.

    Bulletin PWC-94-11 1994 SLT water leaks at steering and reverse cable.

    Bulletin PWC-95-01 1994 SLT Reinforcement of driveshaft through-hull fitting.

    Bulletin PWC-95-04 1995 SLT Loose hose clamp on exhaust cross-over hose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT Is taking on water?
    By normann in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-25-2011, 05:33 PM
  2. 2009 RXT iS taking on water
    By driveumhard in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-01-2011, 10:48 AM
  3. my xlt 1200 is taking in water, in cylinders
    By dropem631 in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 04-03-2010, 01:34 PM
  4. So this guy's GPR is taking on water
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-17-2009, 06:46 PM
  5. 97 spx is taking on water. Any suggestions???
    By dleary46 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-02-2008, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •