Results 1 to 10 of 10
  1. #1
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32

    question about running water threw fx sho

    i noticed while running the hose threw it water only came out by the pump is this normal? also the hose to make the water shoot up out the rear pisser was disconnected.


  2. #2
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by wave15stx View Post
    i noticed while running the hose threw it water only came out by the pump is this normal? also the hose to make the water shoot up out the rear pisser was disconnected.

    You should be getting water out the port side as well.

  3. #3

    Join Date
    Jun 2007
    Location
    Long Island,NY
    Posts
    162
    +1
    12

    sho

    Quote Originally Posted by wave15stx View Post
    i noticed while running the hose threw it water only came out by the pump is this normal? also the hose to make the water shoot up out the rear pisser was disconnected.
    When ski is running on hose water will come out only from pump,there is not enough pressure in hose to force water thru all cooling passages and outlets.Lot's of Yami riders don't like "pissers",so was previous owner.

  4. #4

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    You should be getting water out of the pump area and the pissers on the port side of the hull. Nothing comes out of my starboard pisser, which is the IC pisser and that's why I now flush in fresh water after the salt.

  5. #5
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Quote Originally Posted by SHOdude View Post
    You should be getting water out of the pump area and the pissers on the port side of the hull. Nothing comes out of my starboard pisser, which is the IC pisser and that's why I now flush in fresh water after the salt.
    You ride in the salt! Thought that was not going to happen? Lee

  6. #6

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Quote Originally Posted by L Carlson View Post
    You ride in the salt! Thought that was not going to happen? Lee
    LOL. I don't want the conversion in the salt, my FX can go into the salt.

  7. #7
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Quote Originally Posted by SHOdude View Post
    LOL. I don't want the conversion in the salt, my FX can go into the salt.
    Damn it. conversion in the salt

  8. #8

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Quote Originally Posted by L Carlson View Post
    Damn it. conversion in the salt
    I'll go in salt if it's flat, the chop sucks, don't care about getting wet, but this ski has soooo many air holes in it and salt water gets in there..

  9. #9
    Flash's Avatar
    Join Date
    Feb 2008
    Location
    Phoenix Az
    Posts
    425
    +1
    10
    When I flush my ski with the Salt Away i get water coming out all the ports both sides..you just have to wait a few minutes for all the ports to get water to them.

  10. #10
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by Flash View Post
    When I flush my ski with the Salt Away i get water coming out all the ports both sides..you just have to wait a few minutes for all the ports to get water to them.
    +1.

    On the SHO you should ALWAYS see water coming from the left side pissers when running on the hose. You may or may not see it coming from the right side (IC side). If you don't, try dropping down the front of the trailer as low as it can go and it should start to come out.

    Hope this helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Questions about reflashing the ECU and SHO tuning in general?
    By HybridSS in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-07-2012, 12:15 PM
  2. Question about running in water for first time
    By shaun23a11en in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 05-19-2012, 04:49 PM
  3. flush fitting for running water threw my sho
    By wave15stx in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-14-2009, 03:26 PM
  4. question about bunk adjustment on fx sho
    By wave15stx in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-13-2009, 08:55 PM
  5. Question About the water box mod RXP
    By yellow4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-07-2007, 10:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •