Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    99 XPL dies out at speed

    I have a 99XPL with the following problem:

    It idles well and runs fine up to half throttle but when I open it all the way for about 30 seconds it just dies. I have a R&D flame air filter, solas impeller, have replaced the fuel lines, cleaned the carbs, cleaned the fuel filter, cleaned the Rave valves, etc. I have changed the main jet to 165 and small to 82.5. The engine was rebuilt last year and only has about three hours on the top end. Hope someone can give me some imput.

    **I have found the problem: The front plug is fouling but I am unsure why.
    Last edited by ChipGriffith; 05-24-2009 at 07:46 PM.


  2. #2
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    Is Rave valve the "ON" OFF res switch?

  3. #3
    I am not sure I know what you mean...

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Quote Originally Posted by sleeplessnMS View Post
    Is Rave valve the "ON" OFF res switch?
    Uh, what?

    It sounds like a fuel issue. Did you clean the fuel valve while you were doing the lines and carbs?

    Mr. Incoherent may be asking if it does it in both "On" and "Reserve."

    Also try it with the fuel cap off. A bad intake air check valve can make it pull a vacuum and not flow fuel.

  5. #5
    I did clean the valve switch. The lines and the valve were completely clogged!! I spoke with a friend today and he recommended running it with the gas cap off so I am going to try that tomorrow.

  6. #6
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Also, though it is hard to do on a 947, make sure the supply and return lines did not get mixed up.

    It is unlikely, but in the heat of battle odd things happen.

  7. #7
    Well it was running poorly before we did the thorough cleaning so i hope it is the check valve.

  8. #8
    also change plugs

  9. #9
    Did that too..

  10. #10
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    cleaned the Rave valves, etc.

    LOL! I'm stuck in yami world we call em REED valves I assuming thats what a seadoo "RAVE" valve's are????

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GP 1200 Dying out at High Speed
    By Low Tide in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 06-01-2014, 06:40 AM
  2. 97 GP 1200 Dying out at High Speed
    By Low Tide in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 04-24-2014, 11:36 AM
  3. 97 GP 1200 Dying out at High Speed
    By Low Tide in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-21-2014, 01:04 PM
  4. 01 GPR cutting out at speed
    By TSS73 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-07-2009, 02:58 PM
  5. '99 XPL reaches RPM and Speed
    By jetcar123 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-01-2008, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •