Results 1 to 6 of 6
  1. #1
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943

    PROBLEM 98 gsx 951

    Ok rebuilt engine 150 psi {hot}160{cold}on both cleaned carbs new fuel lines cranks up but after a few seconds it starts idling up and down if ya rev it up it does fine but seems to wanna race up on its on. on the #2 cylinder the plug is running lean. All on trailer havent been in water and its racing up higher than say 3500rpm's I mean to the moon! Here's a question???? While running at idle or up high I pulled the return line off and it spits a little here and there. Doesnt it need to be a constant flow? My tripple pipe has clear fuel lines and the return is allways flowing strong. I'm thinkin the "ON" OFF RES valve is clogged ????? Its like the #2 carb is losing pressure. The fuel enters at #1 and feeds #2 thinkin not enuff volume to make it there. Whatcha guys think?


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    It could be clogged or you could have an air leak.

    What are the low speed adjusters set at?

  3. #3
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    1 1/2 and was at 1 1/8 from well when I got it....

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    That is right.

    A bad check valve on the tank breather line can cause a vacuum in the tank that blocks fuel flow but that usually only shows up under load. Still, running it with the fuel cap off would be the test for that.

    You may indeed need to pull that fuel valve out and clean her up. You can pull the "On" or "Reserve" line off and us a nipple to connect it straight to the line that goes to the filter. If that solves the problem then you know you have a clogged valve.

  5. #5
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    Thanx yea gonna bypass the switch and pull the cap off.

  6. #6
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    OK cleaned the vent and bypassed the on off switch and she is running perfect! Thax 4 da input and advise guys!!!!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 gsx 951 not getting fuel
    By wakejumper48 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-29-2013, 06:32 AM
  2. FS parting out a 98 gsx 951
    By snoproken in forum Sea Doo 2 Stroke Skis
    Replies: 15
    Last Post: 08-24-2012, 08:18 AM
  3. 98 GSX 951 Limited
    By Longer02 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-12-2012, 07:45 AM
  4. FS parting out a 98 GSX 951
    By snoproken in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-21-2011, 09:31 PM
  5. 98 Gsx 951 Limited Problem
    By flyngixxer in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-20-2007, 07:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •