Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Jun 2007
    Location
    Louisburg, NC
    Posts
    88

    HELP!!!!!! 96 xp wont start

    ok my sea doo wont start, i need help. im getting irratated by it because i wanna ride this weekend but it has strong spark, good compression and fuel are on the plugs. It sputters every now and then when i turn it over , it sounds liek it wants to crnk but it dosent. Any ideas to what it can be? im open for anything


  2. #2
    Try switching the fuel selector to reserve.

  3. #3
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    test your compression also.

  4. #4
    I do not know if the motor was apart but rotary valve timing could be a problem. put some fresh plugs in too. drop a little gas in plug hole see if it pops.

  5. #5
    Quote Originally Posted by jeff12pv View Post
    I do not know if the motor was apart but rotary valve timing could be a problem. put some fresh plugs in too. drop a little gas in plug hole see if it pops.
    If it was a rotory valve problem, wouldn't the plugs be soaked with oil, not fuel?

  6. #6

    Maybe

    I know it sounds dumb but a friend of mine pulled his ski about 75 miles so I could see if I could get his so going after he couldn't. It took 2 sec to find the problem and just a few minutes to fix. His choke was on for some reason it was hung shut. Hope your problem is that simple. (no kidding he is a nasa engineer)

  7. #7
    Quote Originally Posted by ultraskiit View Post
    I know it sounds dumb but a friend of mine pulled his ski about 75 miles so I could see if I could get his so going after he couldn't. It took 2 sec to find the problem and just a few minutes to fix. His choke was on for some reason it was hung shut. Hope your problem is that simple. (no kidding he is a nasa engineer)
    Speaking of NASA.........Did anyone see that live feed the other day?

    That was Cool!!

  8. #8
    both fuel and oil pass through rotary valve. If the timing is off it will not run

  9. #9
    Does it backfire?

  10. #10

    Join Date
    Jun 2007
    Location
    Louisburg, NC
    Posts
    88
    i have tried swithcing the fuel selector, it dosent seem to help. the rotary valve hasnt been messed with, the only thing i have done was romove the carbs thats it. i didnt mess with the carbs , adjust them anything. i ran fine before i took it apart. i tried changing the gas out to fresh gas to that didnt help either. I tried putting gas and starting fulid in the cylinders and it didnt do anythingm


    i could try the compression test wiht a gauge next
    150 in each cylinder right??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP wont start while hot.
    By diamondwatercraft in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-08-2013, 07:39 AM
  2. 97 xp wont start need help
    By 2stroker in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-08-2008, 10:31 PM
  3. Need help! 96 xp
    By JacRae in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-21-2007, 10:38 PM
  4. Help!!! my 1300 wont start
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-04-2007, 08:38 AM
  5. Please help! 96 XP plumbing
    By JacRae in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-24-2007, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •