Results 1 to 5 of 5
  1. #1

    MFD not reading gas level

    The sl750 I have, the MFD is blinking that I have no gas in the gas tank, but it's full. Any suggestions?? Thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Your float may have become gas logged and is sunk. You need a replacement float. I think Randy at watcon.com has them.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by beerdart View Post
    Your float may have become gas logged and is sunk. You need a replacement float. I think Randy at watcon.com has them.
    He is correct ^^^^^^. If it has the aluminum pick up tube.

    If you have the old float and arm style, check the connections on the under side. Mine came off and lost the reading.

  4. #4
    I have the same problem with my '95 750 SLT, the shop owner told me his mechanic told him the float is stuck. I didn't think to ask him what may be the exact reasons the float may be stuck (hole in it, pivot point rusted, broken, etc., etc.) I was thinking of adding Seafoam fuel additive to the gasoline, if it is a rust problem the Seafoam additive may break it free. I'm don't know if it will work or not, the only solution may be to replace the sending unit. Any suggestions or comments? Thanks!

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Cambo, the float is most likely gas logged and sunk.

    No need to replace the whole unit. Remove the sender, then the cap on the bottom of the unit. Inside the float should come out.

    Put the float into a cup of gas and see if it floats. If it sinks, you need a new float.

    Randy at Watcon.com sells replacements for around $26.


    Thisa is most likely your problem, not rust.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp Mode - MFD does not display fuel level
    By sgoodman75056 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-04-2009, 03:58 PM
  2. WTB 8 or 12 pin MFD "Not Round"
    By christian79 in forum Polaris Classifieds
    Replies: 0
    Last Post: 05-23-2008, 01:22 PM
  3. MFD only reading .5 volts?
    By Oneboss302 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-16-2007, 08:29 AM
  4. mfd not working
    By LANCE in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-28-2007, 10:39 PM
  5. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •