Results 1 to 9 of 9
  1. #1
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1

    Question Need help with a Carb!!!

    I have an outboard 90 hp force (Chrysler) i believe its a 95. Well I went to put it in today and it started right up. HOWEVER! It is not running at full speed or idling at full idle. I then noticed gas spurting out of what looks like to overflow holes built into the carb. They are very small and ARE suppose to be there. This only happens on 1 of the 3 carbs.

    I am thinking that by sitting all winter (yes it was properly winterized) the carb is stuck closed and no gas is getting to the cylinder to be fired. Instead it is spurting out these two outlets on each side of the carb near the top. (the gas is flowing in but has no place to go but out the over flow holes)

    Does this sound legit? I need help so any help or advice would be greatly appreciated. Thank You


  2. #2
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by AT_Viper View Post
    I have an outboard 90 hp force (Chrysler) i believe its a 95. Well I went to put it in today and it started right up. HOWEVER! It is not running at full speed or idling at full idle. I then noticed gas spurting out of what looks like to overflow holes built into the carb. They are very small and ARE suppose to be there. This only happens on 1 of the 3 carbs.

    I am thinking that by sitting all winter (yes it was properly winterized) the carb is stuck closed and no gas is getting to the cylinder to be fired. Instead it is spurting out these two outlets on each side of the carb near the top. (the gas is flowing in but has no place to go but out the over flow holes)

    Does this sound legit? I need help so any help or advice would be greatly appreciated. Thank You
    weren't force produced by mercury for a time period or am i thinking of mariner....what i would do is take the carb out dissasemble it and clean it out...

  3. #3
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1
    Thats what I was planning. Thanks though. Anyone else have a similar problem with a carb??

  4. #4
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1
    I had it on all day and ran seafoam through it along with carb cleaner and some wrench tapping. It seemed to help a LITTLE bit but not much. I took the carb off now and pulled the needle valve out which had some wear and was indented and worn. So i need a new needle valve that I do know. What i dont know is what else i need to replace? I have never taken a carb apart and dont have a manual. I have the bottom dome off and can see a white plastic ring which i assume is the float. I dont see much else I can take off/apart. Where do I go from here? Everything looks in ok shape. Any guidance would be greatly appreciated

  5. #5
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Worst case scenaro, I had an older 115 merc that had the same problem with one carb turns out it was a broken reed valve! The big problem with that is the reed valves are mounted to the crankshaft!! meaning a full engine tear down!! Hopefully yours is just a stuck float. Keep us posted.

  6. #6
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1
    how do I know its a stuck float? I took it apart now and sprayed EVERYTHING with carb cleaner, inside and out. The float moves up and down fine. The needle valve what wore quite a bit so I know that was part of my problem. Could it have been the whole problem? Let me know and thanks for all your help

  7. #7
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by AT_Viper View Post
    how do I know its a stuck float? I took it apart now and sprayed EVERYTHING with carb cleaner, inside and out. The float moves up and down fine. The needle valve what wore quite a bit so I know that was part of my problem. Could it have been the whole problem? Let me know and thanks for all your help
    i would fix the needle valve then re-install the carb run it see if the proplem still exisists...then go from there

  8. #8
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1
    Could the needle valve cause all that problem? Either way I will do that and post back after the holiday. Thanks again all who helped.

  9. #9
    AT_Viper's Avatar
    Join Date
    May 2009
    Location
    Wisconsin
    Posts
    74
    +1
    1
    Well bad news. I was replacing the float because it was seized up and the metal around the pin holding the float on snapped off. SO i guess now i am looking for a new carb all together.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help with fx1 carb, 44sbn. start to rev when idling.
    By Alex3012red in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 06-25-2014, 08:29 AM
  2. Need Help with SLT780 Carbs
    By toddkageals in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-25-2010, 09:41 PM
  3. Need Help with carbs 96xp!!!!???
    By ashelgren in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-11-2008, 05:17 PM
  4. need help with carbs
    By whiteyz in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 12-03-2007, 10:44 PM
  5. 1999 Polaris Genesis Carb model need help with this one also
    By scottyboat in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-17-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •