Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Need help ASAP!

  1. #1
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360

    Need help ASAP!

    So just got back from LA my phone rings my friends 04 with the same mods my ski has has two dead cyclinders (2 & 3) when I say dead I mean it wont run with the #1 plug wire disconected but the #2 and #3 have no affect on the idle. He pulled the heads off at the lake thinking it was a burned up cyclinder(s) NOPE they look great, there is spark and there appears to br fuel. He also has the VF3's when the ski started having problems he became airborn and heard a loud pop (backfire maybee?) could this have destroyed the reeds? there does not appear to be any material oin the cyclinders? anything else we should look at before ripping the reeds out? also who stock replacement parts for the reeds? thanks guys


  2. #2

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    check your plug wires, I have founds some bad ones lately. Use an ohm meter. and yes a back fire can brake the reeds. check the compresion at WOT and then at idle, if no differance then check the reeds
    Mike

  3. #3
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    So Just got the reeds out the #3 set is destroyed! 2 peddles are gone and the cage is broken at the tip (part closiest to the cylinder) somehow parts of the peddles from the # 3 cylinder got stuck in the #2 cylinders reeds? but they look fine?? these reeds have less than 2 hours on them! Where can I get the parts to fix em?? or maybee they sould go in the garbage?

  4. #4

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    Look on the bright side... ...you found the issue quick! Once you get the parts it's a quick fix. Any ideas how that all happened? I think it's odd to have a two sets that are bad?

    I was told my a two stroke mech. that if you rev the engine and then pull the lanyard to kill it (while it's at a high RPM you can damage the reeds... kind of like when you're clearing the water out after a ride. Just a thought?

    On an other note, looks like I'll have my skis up here in about two weeks. I'm going to be looking for a new double trailer. Can't trust the loaner I got now.

    Talk to you soon,
    Scott

  5. #5
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    NO idea what caused it just hope we can find parts to get her fixed for next weekend! If not back to stock reeds

  6. #6
    need4pwr's Avatar
    Join Date
    Jul 2006
    Location
    New Jersey
    Posts
    330
    How many hours are on those reeds?

    I had a similar issue with the RAD valve setup. Over 40 hours and had to replace them. I heard a snap and thought i broke something, turned out to be the reeds.

  7. #7
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    less than 2 hours on them!

  8. #8
    need4pwr's Avatar
    Join Date
    Jul 2006
    Location
    New Jersey
    Posts
    330
    Quote Originally Posted by r33pwrd
    less than 2 hours on them!

  9. #9
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    well talked with carl at island racing he thinks there was a bad backfire that caused the damage and luckily he is able to get a new cage with reeds for us!! Thanks Carl!

  10. #10

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    That's great!!! :P

    What mods does your friend have? Is he running the right gas for his set up?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help ASAP!
    By 06viperrxp in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-11-2007, 11:09 AM
  2. Need help ASAP
    By SeanJ in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-29-2007, 06:06 PM
  3. Need Help ASAP
    By Yellow04RXP in forum 4-Tec Performance
    Replies: 39
    Last Post: 05-17-2007, 01:48 PM
  4. Need help ASAP pro cdi wiring....
    By Rodneyae in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-05-2007, 08:58 PM
  5. need help asap!!! please
    By nonvtecdaturbo in forum Polaris Open Discussion
    Replies: 23
    Last Post: 12-12-2006, 08:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •