Results 1 to 5 of 5
  1. #1

    Join Date
    May 2009
    Boothbay M.E

    Blown fuse? No display!

    I think i blew my fuse for my digital display when i hooked my jumper pack up. Where is this fuse located? Thanks guys!

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Welcome to the Hulk

    Click here for the Polaris Service manuals, and lots more info.

    What year and model are you asking about?

    The MFD fuse is located inside the electrical box. Only replace it with another 1/4 Amp fuse, not a higher fuse rating.

    There may also be a 3 Amp fuse for the bilge pump in there. You may want to replace that too, since fuses are inexpensive, and it might save you having to open it again later.

    Did you connect the jumper pack incorrectly?

    It is recommended that you do not use external boosters on these machines. Sometimes you can get away with it, and sometimes the voltage spikes damage things.

    Put a decent battery in it, like a factory sealed AGM type battery. Two that work well are the Deka ETX16LM, and the Odyssey PC625

  3. #3

    Join Date
    May 2009
    Boothbay M.E

    Thumbs up

    Hey Thanks alot for the info! It's a 2000 pro 1200. I'm selling it and want everything to work right when someone looks at it

  4. #4
    Ctek's Avatar
    Join Date
    Dec 2008
    Try the simple fix first. Did you push the reset button on the electical box?

    Otherwise K447 has it down. Good news is that is nothing works that is a good indication that it is a fuse. I had that issue as well and the new fuse brought back all the info on my MFD.

    Be sure to post the final resolution for us. Thanks

  5. #5

    Join Date
    May 2009
    Boothbay M.E
    Hey thanks guys! It was just the fuse! Thanks alot! Great sight for info!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Sea Doo XP 787 cc VTS smoking with blown fuse?
    By SmokyTrim in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-29-2013, 11:04 PM
  2. GTX 4 TEC, Long beep and blown fuse. Need advise.
    By Linhster in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-03-2012, 10:57 PM
  3. 260x blown fuse
    By Adolfo in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 02-26-2012, 07:26 PM
  4. Blown fuse on Digital Display 96 Polaris SLT 780. Help!
    By pastordug in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-14-2009, 06:25 PM
  5. Blown fuse 08 SHO... Anyone else???
    By coachfarnen in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 12-14-2008, 01:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts