Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    nps9981's Avatar
    Join Date
    Mar 2009
    Location
    Perrysburg, Oh
    Posts
    68
    +1
    3

    787 carb question

    I have a quick carb question. I haven't been able to get some time out on the river yet but something seemed weird today when I started up my Sea Don't. When I rev it up to about 4500 out of water on the hose the rpms seem to hang for about 3 seconds after I get off the throttle. I can never remember the engine operating like that. The rpms had always dropped down right after I got off the throttle. Makes me think it's too lean. Hopefully I can get some time soon to test it out on the water. Thanks

    LS 1 turn
    75 pilot
    150 main
    HS 1 turn
    1.5 needle
    65 spring


  2. #2
    Mine did that too. It would max out at 7,080 WOT and would idle at 2,300 in the water. Turned out the carb filters were gunked up on the PTO side. Tear the carbs apart and clean them. Clean the fuel selector while you are at it.

  3. #3
    nps9981's Avatar
    Join Date
    Mar 2009
    Location
    Perrysburg, Oh
    Posts
    68
    +1
    3
    Well it's still doing the same thing. Pulled the carbs last night and the filters look clean. I found a little 1211 three bond in the fuel pump that came up from the pulse line. I made sure there wasn't any in the pulse line. I had recently pulled the engine to do an inspection on the crank bearings. I haven't cleaned out the fuel selector yet but it's only 2 years old. I'll do that tonight. I've had to increase the idle quite a bit to get it to idle. I checked the pop off. The pto carb seemed like it was 1-2 psi higher than the mag. I'm not sure of the accuracy of my homemade popoff gauge but I was getting about 25 psi with the 65 gram and 32 psi with the 80. I think my gauge is a little low.

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    You may have an air leak. How many turns out are you on your low speeds? Have you tried increasing them (out)1/4 turn to see if the engine settles down?

  5. #5
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    i have the same problem kinda... took my ski out this past weekend...the bottom end acceleration is fine but it hangs a out at like half throttle constantlly....not allowing it to get up on plane when i have the throttlw wide open.....i just went through and cleaned the carbs before it happened...

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Loosen the gas cap next time and see if it clears up. If so the fuel tank vent check valve is bad.

  7. #7
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by 96XPSS View Post
    Loosen the gas cap next time and see if it clears up. If so the fuel tank vent check valve is bad.
    il try that....thanks

  8. #8
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by 96XPSS View Post
    Loosen the gas cap next time and see if it clears up. If so the fuel tank vent check valve is bad.
    ok loosened the gas cap and it runs like normal! so can the check valve be cleaned somehow or do i need a new one

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Just buy a new one. Pay close attention which direction it installs. Glad that was it!

  10. #10
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    ok so i went out today and it's doing the same thing! so it couldnt be the check valves. So im guessing it's a carb problem, now when i open it full throttle it smokes about twenty times worse then it ever has. like its running with the choke on(rich)i didn't adjust the carbs at all since the rebuild over the winter

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 GTX engine swap question 951 fi to 787 carb
    By Alex3012red in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-12-2014, 11:28 AM
  2. stock 787 engine with buckshot 44 carbs questions?
    By waterdoc in forum Sea Doo Build Threads
    Replies: 0
    Last Post: 06-20-2012, 08:39 PM
  3. 787 carb question
    By ujustlost in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-26-2012, 08:59 PM
  4. 787 engine carb questions
    By abarrassr07 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 02-17-2011, 08:44 AM
  5. STOCK CARB QUESTION
    By Tommy Gun in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-28-2006, 10:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •