Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Unhappy 05 gpr need help!!

    just got back from lake and was ammazed at how slow my ski was with the mods i have, here they are; milled stock head by jim 145-145-140, 14/20 prop, d-plate, home made free flow, r-d plate, ppk, 1300 grate, riva filter with gutted air box, riva efi controler the efi settings i tried was, 5516, 6616, 6626 top speed was only 66.9 gps, mph wtf. i need all the help i can get


  2. #2
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    RPM"S?

  3. #3
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    water conditions,air temps,amount of fuel, on the seat or superman all these come into play....

  4. #4
    i dont have a digital tach but from the display it seems to top out at about 7000 7100 that might not help much but thats all i got my red pod on controler comes on right at 5000

  5. #5
    water was smooth as babys a** and about 1/4 tank of gas air temp was 81 low humidity, also gave it 2 gallons of 110 leaded race gas and about 4 ounces of oil in tank it still has stock oil injec tion

  6. #6
    also on the seat ducked down

  7. #7
    when i pulled the plugs they were alittle wet with fuel also

  8. #8
    zpeters's Avatar
    Join Date
    Jul 2008
    Location
    bayville NJ
    Posts
    437
    Try your top end 66 3 6 That wrked well for me on my ski with almost same mods but my plate i have puts me over 70 mph with my new gps... You def should have some more speed on that baby though... Def should look at the RPMs with a good tach IMO. i just know my upgrades and difference when i run against seadoos and kawa 250s and every mod i see a difference until i finally creep by them now.. soon to be blow by them! haha.. but between a grate you have and free flow i know some ppl might say your losing speed? someone correct me on this?

  9. #9
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Quote Originally Posted by zpeters View Post
    Try your top end 66 3 6 That wrked well for me on my ski with almost same mods but my plate i have puts me over 70 mph with my new gps... You def should have some more speed on that baby though... Def should look at the RPMs with a good tach IMO. i just know my upgrades and difference when i run against seadoos and kawa 250s and every mod i see a difference until i finally creep by them now.. soon to be blow by them! haha.. but between a grate you have and free flow i know some ppl might say your losing speed? someone correct me on this?
    Yes,you will loose some speed with the 1200 grate,free flow.

  10. #10
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    your prop pitch might be a little bit steep for those mods. i'm guessing you're in the 6900 range on rpms...


    need to check the rpms

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brand new 05' r12x need help
    By archie0010 in forum Honda How To & FAQs
    Replies: 6
    Last Post: 07-18-2010, 02:10 PM
  2. Newbie with a 05 rxp needing help!
    By PWC Newbie in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-13-2009, 12:22 AM
  3. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  4. adding X-IC to '05 GTX, need help..
    By Alex13 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-23-2008, 11:24 AM
  5. GPR need HELP
    By jetworx hawaii in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-16-2008, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •