Results 1 to 4 of 4
  1. #1

    I am an idiot...

    Yesterday I put my '01 Ultra 130 into the water for the first day of the season and shortly after starting it (went maybe 10 yards from where I started her which was 4' deeep at that point) I ran over a shallow bar made of mud and gravel and sucked it up into the intake. I feel like an idiot for not seeing it in the shadows. Since the lake is a few feet lower than normal it may have been there buried for years, who knows. The engine choked out on the crap, instinct kicked in from my offroad motorcycle riding and I hit the starter...it clicked and I realized that I should just give up and seek some advice. I ordered a flush kit on the advice of my neighbor, is flushing it out going to help any?

    What should I be doing? I have a shop manual and have some experience wrenching on bikes, but have no experience working on my ski other than pulling the battery. If something is over my head mechanically let me know and I've already got a recommendation for a shop.

    I'm sure this has been discussed before, but I didn't see anything with a search.

    Thanks


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Pull the pump. Bet you got a rock stuck between the impeller and wear ring. You can also try turnning the coupler by hand. Remember you have to have the engine running before you turn on the hose. Otherwise you are going to really f something up.

  3. #3
    DPeteLand PeteSkeet's Avatar
    Join Date
    Jul 2008
    Location
    So-Cal!
    Posts
    697
    Quote Originally Posted by btldigger View Post
    Pull the pump. Bet you got a rock stuck between the impeller and wear ring. You can also try turnning the coupler by hand. Remember you have to have the engine running before you turn on the hose. Otherwise you are going to really f something up.


    yaaaay for hydro locking!

  4. #4
    cameron da river rat's Avatar
    Join Date
    Sep 2006
    Location
    college station, tx
    Posts
    256
    as mentioned above, crawl under and look for a rock, remove grate and remove rock if found, if you dont see a rock, take a flash light and look down the steering nozzle and see if you can see a rock behind the impeller wedged in the stator vein section, if you find one there, you have to take the pump out.

    once you can start the ski, then backflush the cooling system in this order,
    start engine
    crack open water supply (stress the crack open)
    after a couple mins
    shut water off, rev engine to blow water out the pipe
    shut engine off

    a valve on the end of the hose like as in the flush devise helps with the shutting on and off and crack open part.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fully admit I am an idiot but how do I.....
    By jgirvine in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-05-2012, 02:16 PM
  2. XS Intercooler - I am an Idiot
    By tchies in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-11-2010, 09:12 AM
  3. I am such an idiot!
    By 98Hawk in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-21-2007, 09:03 AM
  4. am I an idiot?
    By Fish Man in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 04-24-2007, 10:44 PM
  5. Im An Idiot!
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-26-2006, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •