Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: confused?

  1. #1

    Join Date
    May 2008
    Location
    Osage Beach, MO
    Posts
    51

    mods/speed problem

    For this year i installed a worx crate and a 15/22r solas prop, plugged the rideplate holes, and a 4inch prom filter on my T-X. I took it out today to see how it was running.
    I noticed it idles faster=good
    It cavitates a little= confused because i tried to seal everything real well
    It pulls harder= which is awesome
    It really keeps hooked to the water= great
    The best i got was 68.6mph at 8020rpms with slight chop= thats where i'm really confused

    I haven't replaced the sparkplugs for this year yet, could that be one of the issues? Could someone help me here?


  2. #2

    tx speed

    mabe you need the riva grate with catch can an nozzle from riva i gain 2mph with just the grate

  3. #3

    Join Date
    May 2008
    Location
    Osage Beach, MO
    Posts
    51
    The reason i got the worx was for the water conditions i ride in which are rough alot and i've heard the riva doesn't do very well in that category. I don't really want to spend much more money on modifications this year. My rpms sound like there in the sweet spot, so wheres the speed and what's up with the cavitation? The ski has 54 hours on it, so what could of worn on it other than the oem washers?

  4. #4
    paulthepwner's Avatar
    Join Date
    Mar 2009
    Location
    Middle River, MD
    Posts
    214
    Quote Originally Posted by yfzboy18 View Post
    The reason i got the worx was for the water conditions i ride in which are rough alot and i've heard the riva doesn't do very well in that category. I don't really want to spend much more money on modifications this year. My rpms sound like there in the sweet spot, so wheres the speed and what's up with the cavitation? The ski has 54 hours on it, so what could of worn on it other than the oem washers?
    Have you checked your wear ring? Maybe it got a little torn up when you changed the prop.

    Also, there may be a bit of speed to be gained by checking that all of the blades of the prop are the same pitch. Having a wonky blade or 2 could definitely be causing a problem.

    How much fuel did you have in it when you made your speed run? My T-X runs about 2 MPH faster on 3 bars than a full tank, and it runs 68.6 bone stock in the same conditions.

  5. #5

    Join Date
    May 2008
    Location
    Osage Beach, MO
    Posts
    51
    Quote Originally Posted by paulthepwner View Post
    Have you checked your wear ring? Maybe it got a little torn up when you changed the prop.

    Also, there may be a bit of speed to be gained by checking that all of the blades of the prop are the same pitch. Having a wonky blade or 2 could definitely be causing a problem.

    How much fuel did you have in it when you made your speed run? My T-X runs about 2 MPH faster on 3 bars than a full tank, and it runs 68.6 bone stock in the same conditions.
    the wear ring is pretty much brand new and i dont want to mess with the blades right now, the runs were done with a full tank so that may of been the problem

  6. #6

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by yfzboy18 View Post
    the wear ring is pretty much brand new and i dont want to mess with the blades right now, the runs were done with a full tank so that may of been the problem
    that will be the problem get your fuel on 1 bar for speed runs, and iv'e got a works grate which pulled my speed down, so i took the outer wings off, i still have very good hook up, but thats my couch

  7. #7
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Sounds to me like your speeds are right about where they should be with full fuel. Are you running the filter on the stock air box? It sounds better but won't boost rpms. Time for a kanaflex.

  8. #8
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    15/22r is big bite impeller for the small changes done to the ski tbh.

    It probably is too steep a impeller for your set-up.

    If you put the orig one back in, what will it pull then?

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    I can't say anything more about your speed issue then the others have already. keep searching, you will find it.. the 15/22 can cause some cavitation compared to the stock prop. the stocker is 12 degrees on leading edge. A 14/22 works very well with worx grate. the difference in mph from worx to riva is no more then 1 mph with my findings. By the way I would get some riva washers in your sc asap. good luck!

  10. #10
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Just a thought here..

    Is the rubber sealing ring seated correctly around the front of the pump?

    Sometimes we miss this one.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A bit confused about where water is coming in... Help!
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 04-23-2007, 12:38 PM
  2. Engine trouble... or not - confused!
    By bic1 in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-18-2006, 07:34 AM
  3. Slightly confused about forums now.
    By NCHeel in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-29-2006, 11:04 AM
  4. CONFUSED ON IMPELLER AND INJECTER MODS
    By 4-techscharger in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-21-2006, 02:03 PM
  5. I'm confused on what to get!?
    By Totallyblown in forum 4-Tec Performance
    Replies: 49
    Last Post: 11-20-2005, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •