Results 1 to 5 of 5

Thread: PO337 code

  1. #1
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1

    Question PO337 code

    Built a ski using an 07 motor that suffered a cam chain failure, no start and code po337 (no CPS signal, but CAPS signal good). In my world, I would look to the crank position sensor/wiring for the issue, but don't see how it would be damaged from the chain failure. A cam position sensor failure seems more likely. I am not by the ski right now, but it bugs me thinking about it and thought I could get some input here b4 I go take a look at it again tonight.....Advice/suggestions?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Look at it again... Ron

  3. #3
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    Yeah, gonna look tonight but I tried to fire it this morning and got the code. Was running late and had to go, but it's bugging me, should not be bad, and I KNOW I plugged it in

  4. #4
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    Just got home and on the way I was thinkingand, there are 6 small grounds that bolt to the block, I bolted them in pairs (3 bolts, not 6) and if nothing else jumps out at me when I go look at the sensor/wire, I will correct this b4 replacing the sensor. Ain't this fun?

  5. #5
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    It lives! The temp sensor wire was swapped for the cps.........oops!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. Code PO337, what the eff? Help
    By mstennes in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-10-2012, 08:41 AM
  3. help please!!! urgernt error code PO337
    By jerryspringer in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-07-2009, 06:19 PM
  4. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  5. Getting codes P0261, P0264, and P0267
    By Jrsrxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-27-2005, 02:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •