Results 1 to 6 of 6
  1. #1

    problems with reverse assembly on polaris virage

    I'm having trouble with the reverse assembly on my 2003 Polaris virage. Took it out for the 1st time a last week and it was difficult to shift between forward and reverse, but it would shift with a little double clutch. This last time out the ski shifted into reverse and would not shift from there. I was able to manually disengage the lock and shift the unit, but in looking at the assembly, I'm not sure how to adjust the cam to disengage the lock before the mechanism shifts.

    I've searched the net and a dug through the service manual and haven't seen any kind of recommendation on how to adjust the assembly. Any help would be greatly appreciated.

    Thanks!


  2. #2
    looks like reverse is working ok now. i guess you need to make a quick, firm movement on the handle for it to shift correctly. i stumbled across one of the threads that mentioned lubricating the assembly which i did and seemed to help although i'm not sure that i hit all of the necessary lube points.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272

  4. #4
    That is awesome!!! I guess that I only searched the general discussion area. Sorry for the wasteful post! Thanks!

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by jryan15 View Post
    ... I guess that I only searched the general discussion area.
    Sorry for the wasteful post! Thanks!
    No apology necessary

    If you searched, that is all we ask.

  6. #6
    Just completed the procedure from the other post. That was great! Shifting with minimal effort now. Thanks again!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with Software YDS on GP1300R
    By jack-vc09 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-17-2011, 01:47 PM
  2. CArby problem on polaris virage (yongwang)
    By filopola in forum Polaris Open Discussion
    Replies: 20
    Last Post: 09-24-2010, 08:07 AM
  3. problem with hours counter on RXP
    By RXP rider in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-29-2010, 07:56 AM
  4. Problems with air system on 260x
    By GEKKON4 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-23-2010, 03:03 PM
  5. Any problems with 120 mains on a 1200 GPR?
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-27-2007, 02:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •