Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62

    Question Riva Top Loader Intake Grate for the RXP

    I installed and tested my new Riva Top Loader intake grate today. It makes a warbling noise while making sweeping turns at 30-40mph. It kind of reminds me of a tuning fork. My hole shot is shot. My RXP seems to shutter and shake from a stop. Does anyone know if this is normal for this grate? I like the idea of more top speed, but do not accept the other symptoms. Does anyone know of any mods to this particular intake grate that will allow me more top speed and a fair hole shot? Any help would be greatly appreciated.

    Thanks,

    Craig


  2. #2
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by Craigo View Post
    I installed and tested my new Riva Top Loader intake grate today. It makes a warbling noise while making sweeping turns at 30-40mph. It kind of reminds me of a tuning fork. My hole shot is shot. My RXP seems to shudder and shake from a stop. Does anyone know if this is normal for this grate? I like the idea of more top speed, but do not accept the other symptoms. Does anyone know of any mods to this particular intake grate that will allow me more top speed and a fair hole shot? Any help would be greatly appreciated.

    Thanks,

    Craig
    Not at all,grate helped me all the way around, but now that my carbon seal is shot , so is my hole shot!Warbling sound, yeah mine has always done that

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    That sounds is normal with the intake grate.

  4. #4
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62

    Thanks Guys!

    Why might it shutter from a stop? Any help would be greatly appreciated!

  5. #5
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Something else wrong, could be like mine, stock carbon seal is trashed after 240hours, you might be sucking air through the pump like me. First it shuddered now it sounds like it is just slipping, 0 hole shot.I'm getting ready to order the rad 4 seal from the on line store.

  6. #6
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62

    Thanks.

    I don't know about carbon seals? I had my ski out last weekend and it ran great. I've got 103hrs on it. The only thing I did - is replace the stock intake grate with the Riva Top Loader grate. I guess I could just put the stock grate back in and see if that solves the shuttering problem? My ski didn't have that symptom before.

  7. #7
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    don't think that's it at all. someone else want to chime in. I put mine Riva intake grate on 3 years ago and I haven't had a problem with it since.

  8. #8
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62

    Well enough alone.

    I just discovered alot more water in my hull than usual. I'm not sure if that caused my shuttering issue? I used permatex around the bolts while installing the grate. I don't know what I did? I don't know why there's alot more water in my hull? Any help will be much appreciated.

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    If your carbon ring is worn it can be letting water in the hull and causing that "shuttering" on take off. That shuttering is cavitation from air being sucked in thru the carbon seal.

  10. #10
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by Green Hulk View Post
    If your carbon ring is worn it can be letting water in the hull and causing that "shuttering" on take off. That shuttering is cavitation from air being sucked in thru the carbon seal.
    Hmm .. I bet your right. I inspected the hull and around the new intake grate, everything looks fine. I don't know how to test the carbon ring to see if it is worn. I really don't want to take my ski to the dealer. IMO they are a bunch of idiots who don't really care. I really appreciate your help! What can I purchase from you in order to fix this carbon ring problem? I have the service manual.

    Thanks again for your help!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva top-loader intake grate for Yamaha SHO 08-2011 for sale
    By yamahamiamiski in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-02-2013, 11:02 PM
  2. FS Brand new Riva top-loader intake grate for RXP-X/RXT-X $120
    By rx4pain in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-19-2011, 04:59 PM
  3. FS Brand new Riva top-loader intake grate for RXP-X/RXT-X $120
    By rx4pain in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 05-19-2011, 04:59 PM
  4. FS Brand New Riva Top Loader Intake Grate For The RXT 215
    By Craigo in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 04-16-2011, 08:04 PM
  5. FS RIVA Top-Loader Intake Grate For RXT
    By ADAMBOMB in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 08-24-2010, 10:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •