Results 1 to 7 of 7

Thread: gpr noise

  1. #1

    Join Date
    Mar 2009
    Location
    Ireland
    Posts
    44

    gpr noise

    was out on the gpr today for about 3 hours, ran it when i got out and when i turn it off i can hear metal grinding somewhere around the impeller.the only thing i can put it down to is i took in a bit of seaweed but surly that couldnt bend a blade so as i hits the wear ring???thats all i can put it down to and it rides sweet too


  2. #2
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    Take the pump off, check the wear ring and the prop for any damage.

  3. #3
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Use a garden hose and spray water in the pump from the rear.Might just have some mud/sand or something like that in there. Start the ski for a second and see if it cleared up.

  4. #4

    Join Date
    Mar 2009
    Location
    Ireland
    Posts
    44
    Quote Originally Posted by WATER WOODY View Post
    Use a garden hose and spray water in the pump from the rear.Might just have some mud/sand or something like that in there. Start the ski for a second and see if it cleared up.
    tried that alright ..thats what it sound like but seaweed hardy bent it? there seems to be good clerance bettween prop and ring?.. really dont want to take it off i have so much work on ill never get it back together ha is it a big job?

  5. #5
    DRC 4 LIFE TheDome's Avatar
    Join Date
    Aug 2006
    Location
    Bridge City, Texas
    Posts
    1,257
    +1
    18
    [quote=bounceae86;1078560]tried that alright ..thats what it sound like but seaweed hardy bent it? there seems to be good clerance bettween prop and ring?.. really dont want to take it off i have so much work on ill never get it back together ha is it a big job?[/quot

    Pull the 4 bolts on rideplate and then pull 4 bolts on pump and disconnect hose, not much work at all. Check all pump veins on back side and get a better look at back side of liner.

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    could be the pump bearings are going, mine started to whine and I knew it was time to replace.

  7. #7

    Join Date
    Mar 2009
    Location
    Ireland
    Posts
    44
    was thinking something like that but its too much of a metal on metal sound if you know what i mean,definatly somwhere like impellar,wear ring, shaft etc area, ill have to take it apart and inspect further

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. 07 GPR Flush Noise
    By davids in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 09-30-2008, 10:28 PM
  3. GPR making some weird noise
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 12-26-2005, 05:55 PM
  4. The RXP is 10 times the ski the GPR is
    By LiquidDI in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 05-09-2005, 04:29 PM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •