Results 1 to 6 of 6
  1. #1

    engine breakup past 7/8 throttle

    Like it says my engine's breaking up and loosing speed and rpm past about 7/8 throttle or just below full throttle im getting 81.2mph at 8200 with about 14lbs of boost and my AF gauge is im thinking off but its pig rich at 9.8 at that speed and throttle. Anyone know why when i give it full throttle it hickups and bucks. The other thing to is the boost gauge hits 18-20lbs when i go full throttle. Im thinking its blowing out the spark of something.


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,626
    +1
    806
    sounds like you need to go over your entire fuel system, but first and foremost I would make sure you're not maxing out your fuel pump. make sure there is no blockage anywhere and make sure all of the injectors are firing like they should be.

  3. #3
    Im pretty sure the injectors are good it did the same thing with my 48's in. The fuel pump ive been told is a weak link and i'll have to look over the rest of the system i guess and get this af gauge working.

  4. #4
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,626
    +1
    806
    same thing as with 48s hmmm. what do you have the boost set at? have you tried running a lower psi?

  5. #5
    yup same thing with them. I have the boost to the lowest what im going to try next is to get rid of the boost controller and hook it straight to the wastegate so it defaults to the springs boost rate i hope anyways. I just played with the fuel system a little bit and tried to lower the boost even more took the ski out on the water for about 15 min. same shit and then something happened. It started running weird vibrating real bad and then slowing down like no other then i noticed it was getting heavy in the rear. My seal let go thank god i was next to the boat launch and there were people around to tow me back i almost lost her with a quickness.

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    A/f 9.8 @ wot. That does'nt sound right but if it is that will make it stumble and run bad. You should be shooting for 11.9 A/f. Turn the fuel pressure down about 10-15lbs and see what happens.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2004 MSX 140 engine complete long block with throttle body, stater and flywheel.
    By 800AMSOIL4U in forum Polaris Classifieds
    Replies: 4
    Last Post: 10-10-2015, 11:25 AM
  2. Replies: 3
    Last Post: 07-04-2015, 12:04 PM
  3. 2001 Polaris Virage txi engine cuts out at full throttle
    By Brookie in forum Polaris PWC Performance
    Replies: 11
    Last Post: 08-12-2013, 08:27 AM
  4. 62T Engine Cutting Out above half throttle
    By Beerme in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-03-2011, 08:37 AM
  5. 97 1050SL- No Power Past 1/2 Throttle
    By SkiVT in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-18-2009, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •