Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Join Date
    Apr 2009
    Location
    Ann Arbor Michigan
    Posts
    10

    Low compression in all 3 cylinders.

    I took my ski out the other day and idled out from the dock. The machine would only rev to about 4200 and only go about 43 mph. I changed the oil in it last week and this was the first ride since the change. The machine ran great before the oil change. The machine has not had water injestion or a roll over. I took it to the dealer and it had about 100 psi of compression in each cylinder and oil in sc intake. The machine starts and idles great with no engine noise. The dealer is gonna do a tear down but I was wondering if anyone has any ideas? There are 70 hours on the machine.


  2. #2
    Dave Sharp dav_dman's Avatar
    Join Date
    Aug 2005
    Location
    louisville Ky/so. IN
    Posts
    1,453
    +1
    1
    bet he finds no washers left in the supercharger.

  3. #3

    Join Date
    Apr 2009
    Location
    Ann Arbor Michigan
    Posts
    10
    The dealership said the washers were intact and looked good.

  4. #4
    dduck dduck1628's Avatar
    Join Date
    Apr 2007
    Location
    St Augustine FL
    Posts
    623
    You didn't use a synthetic did you?

  5. #5
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Could you have over fill ed your oil by a bunch!!!

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by GOLD06RXP View Post
    Could you have over fill ed your oil by a bunch!!!
    yep!

  7. #7
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    My ski only has 100 psi compression also but my oil level is fine. I did sink the ski 3 weeks ago and changed the oil 7 times I could have got too much oil in it while I was changing it. How could that hurt compression? Ski runs good

  8. #8

    Join Date
    Apr 2009
    Location
    Ann Arbor Michigan
    Posts
    10
    I did not use synthetic oil and the level was at the full mark.

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Did you check the oil correctly? Get the ski level - either on the water or on the trailer, warm the engine, let the engine idle for 30 seconds, turn off the engine, wait 30 seconds, then check the oil level. If you revved the engine before shutting it off, the level will not be correct... Ron

  10. #10

    Join Date
    Apr 2009
    Location
    Ann Arbor Michigan
    Posts
    10
    The oil level was checked with the machine level and the dealer also said the oil level was correct. I still don't know whats wrong.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dropped compression in all 3 cylinders?
    By mickkkkka in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 02-07-2013, 06:50 AM
  2. low compression in the PTO cylinder
    By lippyat13 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 02-19-2012, 08:20 AM
  3. GP1200r Low Compression In Middle Cylinder...FML
    By GPR305 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-21-2011, 11:10 PM
  4. Low Compression on ALL Cylinders....won't idle - 2005 RXT
    By MJACK in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 11-18-2010, 01:53 PM
  5. Low compression in ALL 3 CYLINDERS..........
    By macio in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 10-04-2010, 12:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •