Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Unhappy 2001 slx mfd probs

    when put in a fresh battery the mfd comes on.. but when it goes into the standby mode if you touch a button it goes dead and won't come back on... once you unplug it and plug it back in it'll come back on again.. but if you touch it when in standby it goes off again... and once battery voltage goes down past 12.6 volts it won't come on at all even when you unplug it and re-plug it in... any ideas??? thanx


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Is the 12.6 volt reading from the MFD, or from a multi-meter on the battery?

    Sounds like there may be a bad wire connection somewhere in the wiring between MFD and electrical box, or inside the electrical box.

    Does the engine crank and start OK?

  3. #3
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Is the 12.6v reading from the gauge? Or with a voltmeter at the battery?

    Does it start?


    Edit; whops,K already asked

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by casey67 View Post
    Is the 12.6v reading from the gauge? Or with a voltmeter at the battery?

    Does it start?
    Touché

  5. #5
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Damn you're fast

  6. #6
    the 12.6 was on the mfd. after on the meter when i check battery with it it was 12.56. the motor cranks.. can't start it cause no fuel... which the mfd did register no fuel when first plugged in and came on... as i said once the voltage was below 12.6 it won't even come on when i unplug it... the voltage is now at 12.48 and mfd ain't coming on...reason voltage dropped is cause i hit the start button a couple times to try to get mfd to wake up when voltage was still up and it did the black out thing... update... went out just now and checked the voltage was 12.18 according to the multimeter down from 12.48 last night... what could be pulling on the battery when nothing is on and the mfd is blacked out??? thanx

  7. #7

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Normal fully charged lead-acid batteries level out at about 12.5 volts when the battery is just sitting. Right after it comes of a battery charger, the voltage will be higher. If the MFD is not going to sleep correctly, it might continue to draw power even though the display is blank.

    Another possibility is that the LR voltage regulator module is sending power to the bilge pump. Put your meter on the Orange wires. They should be zero volts when the engine is not running.

    You MFD should be able to operate down to below 10 volts or so.

    If you are sure all the connections to the MFD are clean, you can try resetting the MFD. This will not work correctly if the power to the MFD is not stable.

  9. #9
    my orange wires are hot... i'm guessing this shouldn't be??? how do i fix this??? also whats it mean if my mfd isn't going to sleep correctly?? i have a red with purple stripe wire coming down from the top of the box and then it is spliced into a orange wire and connected to the orange tree.... i tested it with a volt meter and it has .15 volts coming from it... is this where that wire is suppossed to go?? why does cross to orange? thanx

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by stanger35120 View Post
    my orange wires are hot... i'm guessing this shouldn't be??? how do i fix this???

    also whats it mean if my mfd isn't going to sleep correctly??

    i have a red with purple stripe wire coming down from the top of the box and then it is spliced into a orange wire and connected to the orange tree.... i tested it with a volt meter and it has .15 volts coming from it... is this where that wire is supposed to go?? why does cross to orange?...
    What do you mean by hot? Temperature hot, or that it has voltage?

    There should be one Red/Purple wire coming from the CDI ignition module, and connecting to the Orange wire group. This is an update per Polaris Service Bulletin PWC-00-05.

    0.15 volts isn't very much. If that is all you have on Orange with the engine off, I wouldn't worry about it.

    The MFD sleeps with the time, fuel, and oil levels displayed. Click here for more MFD info.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2001 Slx mfd $40 untested for parts
    By caliburst in forum Polaris Classifieds
    Replies: 4
    Last Post: 01-20-2015, 09:21 AM
  2. Replies: 16
    Last Post: 04-13-2013, 08:31 AM
  3. Who has a 2001 SLX 1200?
    By Sin'sSLX in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-06-2008, 03:09 PM
  4. 2001 SLX Idle adjustment
    By S12L00X in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 06-28-2007, 07:33 AM
  5. 2000 slx mfd/bogging down
    By ozarkvirage in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-15-2007, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •