Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30

Thread: 08 RXTX leak

  1. #1
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9

    08 RXTX leak

    I've been seeing too much water in my hull lately when I pull it out of the lake. At first, I thought it was the newly installed pylon. That was not the problem. Then, I thought maybe it was the front storage bucket not sealing correctly. But, my wife rode it yesterday and she drives it like granny, never getting water over the bow etc. But there was significant water again after the ride. My RXPX was dry as a bone btw.... So this morning with everthing dry, I put the plugs in and filled the hull with water. I started seeing water dripping quite fast from the ride plate area under the pump. It's not the ride plate, the resevoir is still full. Could it be a bad pump seal? I've never removed it before. Could it be something on the driveline?

    Ed


  2. #2
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Did you inspect the intake tunnel for cracks? Seems like ther are quite a few people posting about T-X tunnel cracks.

  3. #3
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by Ziggy View Post
    Did you inspect the intake tunnel for cracks? Seems like ther are quite a few people posting about T-X tunnel cracks.
    I'll check that next.

    Ed

  4. #4
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    I have little spider cracks on one one side of the tunnel.
    They are not wet from my leak test earlier though. Could this be a problem later though?

    Ed
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P5310019.JPG 
Views:	83 
Size:	1.43 MB 
ID:	134319  

  5. #5
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Look at the microfiche:

    http://216.37.204.206/wps/seadoo_oem...=13&A=165&B=13

    Maybe the ride plate fittings are leaking?

    The pump seal wouldn't be an issue, as it isn't sealed from the insde of the hull, however there are lots of things that penetrate the pump shoe and go into the hull (steering rod, speedo cable, etc.). I would think if it were the shaft seal it would be leaking out the thru-hull fitting, and not at the ride plate.

  6. #6

    Join Date
    May 2008
    Location
    Osage Beach, MO
    Posts
    51
    That's what happened to mine, it leaked water in but i don't have any idea how. Its at the dealer right now getting fixed. So i'll probably find out tomorrow and get back to you guys what happened. I'm guessing my pump shoe seal broke open after i hit a duck

  7. #7
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Let that be a lesson learned - always hit ducks high!

  8. #8
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by Ziggy View Post
    Look at the microfiche:

    http://216.37.204.206/wps/seadoo_oem...=13&A=165&B=13

    Maybe the ride plate fittings are leaking?

    The pump seal wouldn't be an issue, as it isn't sealed from the insde of the hull, however there are lots of things that penetrate the pump shoe and go into the hull (steering rod, speedo cable, etc.). I would think if it were the shaft seal it would be leaking out the thru-hull fitting, and not at the ride plate.
    Thanks for the info. If I can't figure it out soon, It's off the the dealer again!

    Ed

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Ed, are you getting any cavitation on a hard take off? If so you could have a leak around your carbon seal.

    What i like to do is take a zip tie that's 3/16" thick and put it between the black accordion boot and where it meets the back of the hull/thru hull fitting.
    This spaces it forward putting more tension on the carbon seal and will help prevent a leak.

  10. #10

    Join Date
    May 2008
    Location
    Osage Beach, MO
    Posts
    51
    oh my gosh, i think that's probably what happened to mine, i was noticing a lot of cavitation all the sudden when i got it out this year and now it leaks water

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 09 FZR vs 08 RXTX : which do I buy?
    By PETRUS in forum Sea Doo Open Discussion
    Replies: 52
    Last Post: 04-20-2009, 01:22 AM
  2. 06RXT vs 08 RXTX
    By gp1200rider in forum 4-Tec Performance
    Replies: 20
    Last Post: 11-24-2008, 07:49 PM
  3. Full '08 RXTX 255 package
    By SideFX in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-19-2008, 04:11 PM
  4. New and need help diagnosing my '08 rxtx
    By dr_hunt in forum 4-Tec Performance
    Replies: 50
    Last Post: 06-28-2008, 06:16 AM
  5. 08 RXTX ECU holds back until certain hours?
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 27
    Last Post: 04-12-2008, 09:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •