Results 1 to 6 of 6
  1. #1

    Join Date
    May 2009
    Location
    Mahtomedi/White Bear Lake MN
    Posts
    6

    95 780 slx no mid range Idle and full throttle is all

    I just bought a 95 slx 750 and it starts up and idles fine but when on the water i go to take off and it falls on its face. If i feather the throttle then i can get it to go up in rpms and then it will take off and run fine. But I cant cruise at half throttle or it will bog down it is either wide open or idle pulled the plugs and they all looked good. im changing the plugs now just incase and put in a half of can of seafoam to try and clean it out a little. Any other ideas or anyone else have this problem. Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Welcome to the Hulk

    Click here for the Polaris Service Manuals.

    There are a number of common things that need attention on the Fuji engined models.

    Click here for a starter list

    Also take the time to scan and read other threads and post involving similar questions from other new Polaris owners.

    The Search feature can also lead you to lots of useful information.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk.

    First do a compression test. Let us know what you find.

    And as a FYI: there is no SLX 750.

    It's either a SL 750

    Or a SLX 780

  4. #4

    Join Date
    May 2009
    Location
    Mahtomedi/White Bear Lake MN
    Posts
    6
    I just got back from the lake i have determined that it is getting to much fuel. starts and idles just bogs down when u give it gas but if i pull the choke for a sec then seems to clear out and takes off and runs good till i i let the rpm come down again. Any ideas? It is a lot better today than yesterday. and it is 780 sorry posted that in heading

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    If you pull the choke and it starts to run good then you have a lean condition. I would say its time for some carb cleaning.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by beerdart View Post
    If you pull the choke and it starts to run good then you have a lean condition. I would say its time for some carb cleaning.
    Correct ^^^^^^^^^

    Also look into new fuel hoses and cleaning the petcock.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 GTX Limited-No mid range
    By dpfly in forum Sea Doo How To & FAQs
    Replies: 10
    Last Post: 05-07-2013, 09:32 PM
  2. no mid range power help!
    By Corey_ in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-28-2012, 04:48 PM
  3. What carb springs to use 95 780 SLX?
    By cigarlust in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-16-2012, 04:29 PM
  4. 95 780 slx leaking oil??
    By lichevyguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-04-2010, 10:40 PM
  5. GPR no mid range
    By vipe6000 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-29-2010, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •