Results 1 to 8 of 8
  1. #1

    flushed my brand new ski wrong rxtx 255

    i rode today and was very tired when i got home. I made a huge mistake. I started the water before the ski, once the water was on i started the ski, then i cut the ski off with the water still on. I was very quick though with the water cut off and on, however i am very nervous i may have ruined it. what should i do??? much help appreciated!!!


  2. #2
    jwade's Avatar
    Join Date
    May 2007
    Location
    Clarksville, Tn
    Posts
    228
    Did you start it again after all all that to ensure it turned over?

  3. #3
    Joe
    Join Date
    Jul 2008
    Posts
    248

    Done it a couple of times.....

    and had no problems at all.....

    unless someone tells me that my VTS is broke because of this!!!!

  4. #4
    yes just ran it for about 30 seconds to run rest of water out, maybe a quart came out tops thats it. it started right up!!! so i guess im good!!!

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by just2quick_rxtx View Post
    yes just ran it for about 30 seconds to run rest of water out, maybe a quart came out tops thats it. it started right up!!! so i guess im good!!!
    Yep, you are good to go.

    Running the water that short of a time without the engine running will not hurt anything.... don't run the water any longer than that though

  6. #6
    seadooridah's Avatar
    Join Date
    Jan 2009
    Location
    Grand Cayman, Cayman Islands
    Posts
    137
    +1
    1
    Yea man, should be fine, iv done it quite a number of times n it hasnt affected anything

  7. #7
    Avion3333's Avatar
    Join Date
    Dec 2007
    Location
    Cayman Islands
    Posts
    686
    as long as your waterbox isnt full you should b fine

  8. #8
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum just2quick!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do i have a bad starter in my brand new ski?
    By truwrxtacy in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 06-22-2015, 09:59 AM
  2. FS Brand New X Charger for 255 HP skis
    By sweetbats in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 11-21-2009, 10:35 PM
  3. Need some feedback about a issue i had with my brand new ski
    By iceblu121 in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-28-2009, 07:14 PM
  4. Pretty sure my brand new engine is toast
    By SantaCruz163 in forum Polaris Open Discussion
    Replies: 25
    Last Post: 06-08-2008, 03:19 AM
  5. My brand new boat from U.S.A
    By qatar2000kk in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 10-23-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •