Results 1 to 7 of 7
  1. #1

    slx 780 slow rpms at top

    hi guys, had my slx out again last night and when i open it up the rpms go to around 5600 and stay for a few seconds then slowly move to 6300 then drop slowly to 6150 then creep back to 6340 on the mfd, it's like the engine has too much load on it at higher speed, is it possible adjusting the trim down (nose down) to far could cause this?i removed the sponsons to be able to spin a litle more freely and adjusted the trim to try to stop porposing (good luck there haha) also with the trim down i lose top speen but dont porpose, is this just nature of the best? only one rider about 162lbs. ( I believ the rpms dont get slugged down as much whithout the trim that far down, just wana know if im stressing the motor to much and causing this) thanks in advance


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Sounds like a carburetor problem.

    Have the carbs been cleaned/rebuilt in recent memory?

    If you don't have it yet, click here for the Service manual.

    Do not continue to run the engine at high throttle levels until you get this problem solved. Lean fuel delivery can burn holes through the pistons in short order - minutes or even seconds.

    Have you read through the common issues that apply to the Fuji engine Polaris?

  3. #3
    the carbs have about 10 hours on them since an overhaul and the piston wash looks ok, if you were to cut a quater in half, thats about the size of wash im getting outta it(all 3), on its display(not gps, i know) it's getting to 59 mph when the trim is not pointing all the way down, maybe a third of the way up, but no sponsons = porposing, thats why i adjusted the trim down with the rod from the trim motor to the nozzle.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    So it is doing the engine RPM surge thing when the hull is bouncing up and down some?

    I wonder if the fuel lines are leaking air into the fuel system The fuel system is under suction from the tank to the fuel pump, so any leaks will leak air into the fuel, not leak fuel out.

    Have the fuel hoses been changed, or original?
    Air leaks at the fittings, filters, or the fuel selector valve?

    If your model year SLX 780 has flexible fuel lines inside the fuel tank, they can also degrade and leak air into the fuel supply.

  5. #5
    i got it, pto carb had a small tear in the diaphram, went to go buy a new one, they wanted like $60 for a new one. talked to my yamaha dealer who had an everyday Mukini carb diaphram as he called it (exact same carbs that yama uses as well on their pwc's) $14!! thats a saving!!

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Is the engine now running properly?

  7. #7
    yup runs good now, no surging and lots of power again, good news that yamaha uses the same diaphram, that saved me a ton, haha im thinking im gonna have to open my other one (sl750) up a lilttle bit it's looking a lil lean? wierd thing is it's never had a lean condition and never been touched in 3 years... but it does have mixed fuel in it with the injector system running...oh well going rich shouldn't hurt it right? or wrong?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Genesis is losing 1000 RPM at top speed now and then
    By travis ingram in forum Polaris Open Discussion
    Replies: 20
    Last Post: 09-06-2012, 10:58 AM
  2. 780 slt dies at top speed
    By chinman in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-10-2012, 10:25 PM
  3. SLX 780 acting funny after top end rebuild
    By Beachbum3478 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-15-2010, 10:48 PM
  4. 1996 Polaris SLX 780 breaking up at full load, hmmmm?!?!?
    By TechSLX in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-15-2008, 09:31 PM
  5. Slx 780 Cutting Out At High Speeds
    By BRANDON in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-03-2007, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •