Results 1 to 5 of 5
  1. #1

    1996 Polaris SLTX No Spark troubleshooting question

    I recently rebuilt a '96 SLTX and it doesn't spark. It was pieces when I got it and I don't know if anything worked (Electronic wise) before. What is the best way to troubleshoot it and isolate the electronic problem?

    Thank you,

    Aaron


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Do you have the Service manual?

    You will have to do some troubleshooting, since the machine was in pieces.

    Trace all the wiring, comparing it to the wiring diagram in the service manual. Pay particular attention to the ground connections - make sure they really are zero ohms, all the way back to the battery negative.

    Also have a look at the Service Bulletins, as some may apply to your model.

    Follow the links above for additional useful info.

    Also read up on the Ignition System Update Kits.

    If you haven't already, replace those gray Tempo fuel lines.

    Have the carbs been cleaned and rebuilt?

    Before you get too deep into the wiring, make sure the battery is actually good enough.

  3. #3
    I have a manual. I have completely rebuilt the engine to include fuel system. I connected all of the wires according to the wiring diagram in the my manual.

    Had to buy a new CDI because the one coming with the ski had a hole burnt through the outer plastic (fried). This would leave me to believe that the stator was also damaged from the CDI burning up. I just need to make sure that it is the stator before I spend $200 on a new one or go through the trouble of taking it out. When I had it out, it didn't look damaged or smell like burnt electronics.

    I have a brand new battery tested it before, checked the drop from the draw of the starter. All was good

  4. #4

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    doesnt take much to ruin these stators , down load the manuel or go to the tech tips side look for domestic eletrical look for stator test , it will involve a 9v battery and your multimeter

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by aaron85207arizona View Post
    I have a manual.

    ...leave me to believe that the stator was also damaged from the CDI burning up. I just need to make sure that it is the stator...
    Did you click the link?

    Stator checks are outlined in the Polaris service manual, and on several other threads.

    Check the stator coil ohms, also check for coil shorts to ground, and check the Hall Effect sensor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLTX runs and starts easily but has no power?
    By PWCGUYWI in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-10-2017, 08:37 PM
  2. 1996 Polaris SL780 No spark
    By duckdrive in forum Polaris PWC Performance
    Replies: 10
    Last Post: 07-19-2015, 11:29 AM
  3. 1996 Polaris sltx 780 NO SPARK
    By Tkcrook4 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-20-2015, 12:47 PM
  4. 1996 Polaris sltx, QUESTION
    By jasonmd13 in forum Polaris Open Discussion
    Replies: 43
    Last Post: 04-03-2013, 07:44 PM
  5. 1996 polaris sl780 no spark Everything I have tested is good
    By sarah719 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-31-2011, 10:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •