Results 1 to 3 of 3
  1. #1
    Wetracer's Avatar
    Join Date
    Dec 2006
    Location
    Pacific Northwet
    Posts
    156

    Polaris Virage TXI 1200

    Has anyone had problems with the Flywheels cracking on this ski???


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Did the magnets come loose?

    I think Bernie has seen that problem.

  3. #3
    Wetracer's Avatar
    Join Date
    Dec 2006
    Location
    Pacific Northwet
    Posts
    156

    flywheel

    Yep magnets cracked and came apart and destroyed the stator. Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris virage txi 1200 idles and dies
    By mouamax in forum Polaris Open Discussion
    Replies: 35
    Last Post: 06-06-2016, 11:09 PM
  2. 2002 Polaris Virage TXi 1200 - Help help help!!! No spark???
    By REV968 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-23-2015, 09:19 PM
  3. 2002 Polaris Virage TXI 1200 ?
    By sledheads4 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-23-2011, 09:49 AM
  4. 2001 polaris Virage TXI 1200 Stutters and lacks power HELP!!!!
    By 1_kwik_virage in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-02-2010, 04:34 AM
  5. help! 2002 Polaris Virage TXI 1200
    By PERCMAN25 in forum Polaris Open Discussion
    Replies: 43
    Last Post: 06-08-2010, 12:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •