Results 1 to 8 of 8
  1. #1
    SGAVIN's Avatar
    Join Date
    Jan 2008
    Location
    Norwalk, Iowa
    Posts
    34

    XPL Problems Help!!!!!!!!

    I have a carb XPL, ski runs fine for 5-10 minutes. After that the ski wants to fall on it's face. Carbs are rebuilt, new fuellines, fuel system has totally been checked out. This ski runs perfect at first and then after that time it goes to crap. Compression checked, cylinder walls, pistons checked. Anybody had a problem like this. Unhooked heat sensor to the head still no difference, plugs look good. Thanks


  2. #2
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4
    make sure fuel vent not blocked

  3. #3
    Have you tried switching the fuel selector? It will tell you if its in the baffel. I know you said the plugs look good, have you tried new plugs? Water in fuel maybe? Takes some time to work towards the carbs maybe.

  4. #4
    SGAVIN's Avatar
    Join Date
    Jan 2008
    Location
    Norwalk, Iowa
    Posts
    34
    no fuel selector on ski, hooked up direct to reserve side. fresh fuel.. Checking the vent. It's weird because it runs perfect and then starts acting up.

  5. #5
    Leendert's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, Florida, United States
    Posts
    918
    +1
    73
    Ok goes to Crap, what does that mean,? Engine shuts down? rus bad ? What do you do afterwards let it sit and after 5 mins ? an hour It works fine again? In other words what happens after it goes to crap?

  6. #6
    If the (2) one-way Vent Valves are installed backwards the Fuel Tank will either pressurize or not vent in to relief the vacuum created as fuel is used. (rare)

    Try running with your Fuel Cap cracked to equalize pressure of the Fuel Tank to atmosphere to verify this is whats happening. Otherwise go over your Fuel line ==> Barb. connections on theFuel Tank Baffle to verify the right hose is on the right Barb.

    Here is a Fuel System diagram of your ski.
    http://216.37.204.206/wps/seadoo_oem...e=13&A=55&B=15

    David
    Last edited by David_HX_RXP; 06-05-2009 at 10:03 PM. Reason: x

  7. #7
    SGAVIN's Avatar
    Join Date
    Jan 2008
    Location
    Norwalk, Iowa
    Posts
    34
    Ski runs up to speed then bogs out and falls on it face. Give a few seconds does the same thing again. My friend did a conversion and took a XPL DI and switched everything over from a carb model. I think he has the fuel vents mixed up. That makes the most sense for right now. He had all that stuff out and had to put back in. We'll check per diagram and make sure that is right. Thanks for the help.

  8. #8
    Quote Originally Posted by David_HX_RXP View Post
    If the (2) one-way Vent Valves are installed backwards the Fuel Tank will either pressurize or not vent in to relief the vacuum created as fuel is used. (rare)

    Try running with your Fuel Cap cracked to equalize pressure of the Fuel Tank to atmosphere to verify this is whats happening. Otherwise go over your Fuel line ==> Barb. connections on theFuel Tank Baffle to verify the right hose is on the right Barb.

    Here is a Fuel System diagram of your ski.
    http://216.37.204.206/wps/seadoo_oem...e=13&A=55&B=15

    David

    +1. Take the tank vent off, and with an air compressor, gently blow air through the 2 check valves. If they will not pass air into the tank, fuel will not want to flow out of the tank. Think like a gas can, you open the air flap and she flows free. Same concept.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Common 1998 XPL Problems and fix help
    By Skripo in forum 2-Stroke Performance
    Replies: 12
    Last Post: 09-20-2007, 09:45 PM
  2. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM
  3. Weird voltage drop problem help!
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 07-29-2006, 08:08 PM
  4. RXP problems... help
    By mgo7483 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-03-2006, 06:13 PM
  5. GP1200R Problems - HELP!!!
    By ramnj in forum Yamaha PWC Performance (2-stroke)
    Replies: 47
    Last Post: 06-05-2006, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •