Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Trouble with DESS Key! please HELP!

    well I have a 2005 Rxp and last week it didn't want to start,...Or more like it was having trouble reading the key,...But eventually started???? Now its reading Key sensor on the screen?? and makes a click when I try to start it, could this be an easy fix for me? I really cant afford for the shop to take a look at it with their hourly shop RATES!

    Thanks
    Hector!


  2. #2

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    sounds like a flat battery or your starter motor is shot, put the jump leads on, (but dont start the vehicle that the jump battery is on) try it now with your dess key, if that fails and you still get a click, the salonoid has to be checked, remove the dess key and follow the red lead from the battery to the salonoid, pull back both red plastic shields off the salonoid posts, put a spanner across both posts (making sure you dont touch earth with spanner) if engine doesnt crank the starter is shot, hope this helps

  3. #3
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Soulds like a bad battery or bad connections

  4. #4

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by Hector_750 View Post
    well I have a 2005 Rxp and last week it didn't want to start,...Or more like it was having trouble reading the key,...But eventually started???? Now its reading Key sensor on the screen?? and makes a click when I try to start it, could this be an easy fix for me? I really cant afford for the shop to take a look at it with their hourly shop RATES!

    Thanks
    Hector!
    did you get that?

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,626
    +1
    806
    Does it eventually start after making the clicking noise? If so, I would recommend replacing the starter relay, located on the side of the MPEM, for approx. $40. It's the tan piece with the battery connections hooked to it.

  6. #6
    Thanks guys I am going to try that when I get off work tomorrow afternoon and I'll let you know how it goes!!

    Again Thanks I have'nt been on the forum in a while but glad I can depend on you guys!
    Thanks
    Hector!!

  7. #7
    JFizzle,

    It did start at one point after a few try's but now it just clicks!

  8. #8
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Trust me bad battery or corroded connections. Have the battery load tested and clean the connection. If it still persists then change the solenoid.

  9. #9
    Ok guys I tried a new battery from my rxp-x and still no luck, I tried touching the starter post to the battery post and no luck either, then I tried the same thing on my RXP-X and it worked it tried to turn over, So.... Do you guys think my starter is shot? what does something like that cost to fix? or do you still think I should replace the selenoid? OH I tried jumping it off and the new battery but this time all it did when i inserted the Key it had a Long Beap and nothing showed on the screen it just stayed Blank! Could it be something else besides the starter?

  10. #10
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Hector... just something else to check. Look in the cap of the DESS key. You should see a metal strip along the back and two metal strips up the sides (across from each other). Just make sure they are still intact and not bent over or missing altogether. The problem is most likely a battery/solenoid/starter issue, but it can't hurt to check the DESS key.

    Jeff

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Need a mpem for a 97 xp 787 with dess key
    By onefastgpr619 in forum Sea Doo Classifieds
    Replies: 10
    Last Post: 06-21-2010, 11:16 PM
  2. FS 1998 GTX limited MPEM with dess key
    By Piranha Performance in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 06-06-2010, 02:30 PM
  3. Problem with 2003 GP1300R Please help
    By amf133 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-27-2010, 02:51 AM
  4. RXT Troubles! Stumped on Problem, please help!
    By pachi33 in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-11-2009, 12:29 PM
  5. Crazy Problem with RXPX display..Please Help?
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-03-2008, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •