Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Jan 2008
    Location
    Clermont FL.
    Posts
    227

    4 tec locked up have questions

    While out Sat. rpm dropped from 8350 to 7900 then engine shut down. Took the driveshaft out found nothing, but when I pulled the supercharger off it was locked up. About 50 hrs. ago had steel washers, ceramic bearings and green wheel put in. The bearings are wiped out also the green wheel. Can I crank the engine to see if anything else broke should I pull the oil pumps first where do I start to straighten out the mess. Can I pull the pumps without pulling the engine never had one out before. Guess it is time to check out another supercharger. This is a 05 RXP
    Last edited by divin10; 06-07-2009 at 02:06 PM. Reason: add info


  2. #2

    Join Date
    Jan 2008
    Location
    Clermont FL.
    Posts
    227

    4 tec

    is there anybody with a little guidance

  3. #3
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    Quote Originally Posted by divin10 View Post
    is there anybody with a little guidance
    My 05 GTX did the EXACT same thing two weeks ago at Norris Lake. I thought the battery was weak! The SC locked up the motor!

    1) Make SURE all 7 balls and any pieces are still in the SC not down in the engine!
    2) Remove and clean the intercooler (easy to do)
    3) Remove and clean the oil screen below the Intercooler (also easy)
    4) Wipe out any aluminum dust on the hoses from the SC and the inside of the intake manifold
    5) Change Oil and filter
    6) Install NEW SC

    mine is running great after doing this just this past week.

    Jon

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You need to account for all the ball bearings. IIRC there are 8 balls per bearing. It's hard to imagine how much leverage the SC has on the flywheel - enough to stop the engine... Ron

  5. #5

    Join Date
    Jan 2008
    Location
    Clermont FL.
    Posts
    227

    rxp

    I don't have them all that's for sure maybe in the oil pump. Where is the oil screen intercooler looks clean will blow it out.
    Last edited by divin10; 06-08-2009 at 05:17 PM. Reason: more info

  6. #6
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Was this a ceramic bearing failure?

  7. #7

    Join Date
    Jan 2008
    Location
    Clermont FL.
    Posts
    227

    rxp

    Yep ceramic bearings

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by SeaGoat View Post
    Was this a ceramic bearing failure?
    Appears to be another one... those things suck and should be removed from stores ...

  9. #9
    Golden Jet red fox's Avatar
    Join Date
    Dec 2008
    Location
    DiJeddah
    Posts
    322
    Quote Originally Posted by bigdaddyRXP View Post
    Appears to be another one... those things suck and should be removed from stores ...
    Oops i have one set ..... i thinking about install it !!!!

  10. #10
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by divin10 View Post
    I don't have them all that's for sure maybe in the oil pump. Where is the oil screen intercooler looks clean will blow it out.
    There are screens in the front and rear oil pumps... the cover on the rear has to be pulled to get to it... but it can be done in the ski.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have the steering lock up either left or right? 14' Tx-As
    By coachfarnen in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-22-2016, 06:48 AM
  2. Help needed to diagnose a locked up 2002 4 Tec 155HP
    By Doo Crazy in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-25-2014, 12:56 AM
  3. Locked Up Pump - Questions
    By rob2337 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-14-2009, 01:25 PM
  4. oil alarm how long do you have before lock up
    By patrick webb in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 07-26-2009, 08:25 PM
  5. picked up my 06 rxp today, and now have questions about break-in??
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-29-2007, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •