Results 1 to 8 of 8
  1. #1

    help with 07 rxp!!

    gentlemen i would really apreciate if you guys could help me out on this one- every time i ride my ski i end up haveing dried salt water residue all over the top and rear part of my engine. originally i thought it was my seat dripping salt onto the engine. The question i have for you guys is can it be a loose hose? are there any hoses towards the rear of the engine that have salt water run through them that i should check- thanks in advance.


  2. #2
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708
    Quote Originally Posted by adrielmc View Post
    gentlemen i would really apreciate if you guys could help me out on this one- every time i ride my ski i end up haveing dried salt water residue all over the top and rear part of my engine. originally i thought it was my seat dripping salt onto the engine. The question i have for you guys is can it be a loose hose? are there any hoses towards the rear of the engine that have salt water run through them that i should check- thanks in advance.

    Hose from rear pump area to your exhaust? That hose runs water from wherever your riding through your ski. That would be my guess. Check the hoses coming from the back of the ski to your exhaust.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    It could be your carbon seal slinging water.

  4. #4
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    If the carbon seal was leaking a little, perhaps it could throw water up there. Don't know for sure.

    OBJ

  5. #5
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    Check the stainless steel exhaust J pipe, mine developed a hairline crack, only discovered it while running ski on hose, welded and is fine now.

  6. #6
    Thanks you all for the quick replies- now what is the best way to check for the leaks

  7. #7
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    On a trailer, put water inside using a hose see if it "leaks out" anywhere.

    To check other, run engine hooked to hose and visually check for leaks.
    Be SURE to in order :

    1) start ski
    2) then turn on hose connected to engine
    3)turn off hose
    4) then OK to shut off engine.

  8. #8
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by adrielmc View Post
    gentlemen i would really apreciate if you guys could help me out on this one- every time i ride my ski i end up haveing dried salt water residue all over the top and rear part of my engine. originally i thought it was my seat dripping salt onto the engine. The question i have for you guys is can it be a loose hose? are there any hoses towards the rear of the engine that have salt water run through them that i should check- thanks in advance.
    I ride fresh water 90% of the time, no leaks. The 10% I ride in the ocean, it looks just as you described. The salt air/mist covers my engine, so a good washing and a little silicone and it's all gone. I don't even sweat it anymore. It's a fact, unless you ride like Jammmer 1 does.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parts needed. Help with my RXP build
    By caliburst in forum Sea Doo Classifieds
    Replies: 30
    Last Post: 11-03-2008, 06:19 PM
  2. Help with 07 RXP
    By fastskipper in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-10-2008, 04:56 PM
  3. Newbie needs help with 07 RXT
    By RobbieMWD in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 05-21-2008, 07:17 PM
  4. help help with my rxp 2006
    By dxb555 in forum 4-Tec Performance
    Replies: 5
    Last Post: 11-21-2007, 03:48 PM
  5. New to Forum-Need help with 07 GTX
    By Live Fast in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-17-2007, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •