Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: MFD

  1. #1

    MFD

    does anyone have a used still working MFD display or does anyone know where i can get a used one.


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    I don't know what ski you need it for as you didn't say, but you can find an oval one here. Lugs is a standup guy you can trust.

  3. #3
    its for a 96 slt 780
    ill check it out thanks

  4. #4
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    Have you tried fixing the one you have? reset procedure? cut it open and clean the contacts!

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Have you confirmed that your MFD is really dead?

    1/4 Amp fuse in the electrical box is good?
    Ground, Red/Purple power wires to MFD good?

    Click here for more info on how to repair faded MFD digits, or reset the MFD.

  6. #6
    well its not really dead thats what i dont understand the fuses are good and the ground is good, i even cut it open and cleand it and i have tried to reset it but nothing happens the display shows something but i dont know what it means does any one of you know what it means?Click image for larger version. 

Name:	SSPX0236.jpg 
Views:	29 
Size:	474.6 KB 
ID:	136215

    Click image for larger version. 

Name:	SSPX0235.jpg 
Views:	33 
Size:	379.0 KB 
ID:	136214

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Looks like the repair didn't work properly.

    I think the LCD contact strip isn't working, so you are just seeing partial digits.

  8. #8
    do you know how i can fix it? or do i just have to get a different one

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by bbah111 View Post
    ...I even cut it open and cleaned it...
    Quote Originally Posted by K447 View Post
    ...I think the LCD contact strip isn't working, so you are just seeing partial digits.
    Quote Originally Posted by bbah111 View Post
    do you know how i can fix it?...
    Did you already do the MFD repair that is described here?

  10. #10
    yes i have already tried it as described on the link

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MFD mounting for a PRO 1200
    By Hayabusa in forum Polaris How To & FAQs
    Replies: 25
    Last Post: 08-18-2010, 08:57 AM
  2. Replies: 16
    Last Post: 09-22-2006, 07:02 PM
  3. Charging. What voltage/MFD problem
    By 2kids3pets in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 09-06-2006, 09:42 AM
  4. Resetting a Polaris LoPwr MFD
    By javiert99 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-03-2006, 11:54 AM
  5. MFD Type I & II
    By beerdart in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-23-2006, 12:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •