Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    1996 gtx loses power at 6500 rpm

    I just bought a 1996 gtx 800.To start I love this forum.This gtx has 90 hrs on it with 15 hours on new top end.It runs great till 6500 rpm all day if you try and hold it wild open it starts to die and sometimes quit but will fire right up and go like a scared rabbit to 6500 rpm and about 47-48 mph.It has new impeller and flame arrestor filters.The oil injection has been removed and was told the carbs where rebuild and high flow fuel pump.The choke is removed and now has primer.I've read quite a few posts and I'm no smarter.Seems like it could be the rectifier or the fuel shut off or wrong jetting for flame arrestors (Located in upper michigan).All the fuel lines where changed not to sure if filters where?Any help would be great Thanks


  2. #2
    Anybody have any idea?I'm goin for a ride on it tomorrow and try the fuek shut-off on reserve to see if it is that and do some plug readings when it quits

  3. #3

    updated

    I tried it in the yard today with the water hose hooked up to it too keep it cool.It idles at about 4000 rpm You have to uses the primer to get it down to 2000-2500 rpm and soon as you touch the throttle its back to 4000 rpm, and if you rev it up it stays around 6500-7000 rpm and you have to pull the dess cord to get it too come off 7000 rpm and it takes a couple seonds too get off 7000 rpm.It seems like the thing revs to the moon and is out of control.I dont know if in the water its hitting the rev limitor and shutting off or what?

  4. #4
    sounds like we have the exact opposite problem, lol

  5. #5

    Join Date
    Jan 2006
    Location
    Taylor, MI 48180
    Posts
    321
    +1
    7
    Check your RAVE valves, for leaks, sticking and or adjustment. Should move very smoothly. If not pull them a part and clean them.

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by soogtxguy View Post
    I tried it in the yard today with the water hose hooked up to it too keep it cool.It idles at about 4000 rpm You have to uses the primer to get it down to 2000-2500 rpm and soon as you touch the throttle its back to 4000 rpm, and if you rev it up it stays around 6500-7000 rpm and you have to pull the dess cord to get it too come off 7000 rpm and it takes a couple seonds too get off 7000 rpm.It seems like the thing revs to the moon and is out of control.I dont know if in the water its hitting the rev limitor and shutting off or what?
    Glow-plugging is when the tip of the spark plug becomes so hot (from being lean) it ignites the air-fuel mixture with no spark. This is very BAD on an engine's bearings, and shortens engine life. It revs uncontrollably and up to 10k rpm. All you have to do is pump the primer a couple squirts and she will settle down immediately. Try to never let your engine glow-plug. It will only doo this out of the water as it has no load on it.

    When it idles high from the get-go, (should be @ 3k out of water) and won't settle down after a rev, it is lean. My first suspect would be the internal filter screens inside the carbs, are plugged. Then fuel selector switch.

    Sorry I didn't see this thread sooner...didn't want you to be ignored!

    Do a search. The Mikuni carb manual link is available here for dowloading. I've posted it many times. Good luck, and welcome to GH!

  7. #7
    I took it out tonight to see how made it was for a good ride.It will run close to 6000-6500 rpm then cut out. It has a primer kit on it and if you use the primer it will hold the revs up and you can get some decent speed out of it.It seems like it is starving for fuel.I brought it back to the garage a tore the carbs apart. It has a ocean pro racing intake spacer and tau-ceti pro series flame arrestors and pre-filters on them.The carbs are clean as are the filters.I noticed that it has 142.5 mains and 70 pilots.With the intake and flame arrestors would you have to rejet? i think that these are stock.It idles at 2400 rpm in the water.When you hit the throttle it hits 7000 rpm and pulls right out of the water then cuts out like it run out of fuel.If you ease back into it it will run 6000 rpm it if you try anymore it will cut out and if you use the primer you can hold around 6500 rpm but its really jerky to keep running.Thanks for any help

  8. #8
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    RQ knows the jetting for the carbs. When you get those from him, check yours and then put the carbs back together. If it still does it, you have an air leak. I was with Robert about the filters being clogged, but you ruled that one out already. Also while your at it, take out your fuel selector switch and clean it.
    SHOOTER

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Change the jetting to 75 pilots. You also need 2.0 needle and seats, and 80 gram springs. You probably still have the stock 1.5 needle and seats, with 95 gram springs in there.

    For sure, you will seize a piston if you keep attempting to run it wot and it's lean. If....you haven't already done so.

    And pull the fuel selector switch and clean it like Shooter advised. They are bad about the inner rubber liner shifting and blocking fuel flow. Try running it on reserve and see if it maintains max rpms. You also need to verify the fuel pump mica check valves on the front carb. If one is cracked or the rubber nipple loose, it pumps fuel at half capacity.

  10. #10
    The gtx has an aftermarket fuel pump already on it from the last guy.It looks to me like he tried everything but rejet it.He needed green hulk forums and he would have saved some cash.When you say 95 gram springs you mean needle and seat springs?It came with 2 carb kits but all stock parts in them. Never had to change these before, lots of snowmobile jetting and street bikes but ostly pilots and mains.I tried running it on reserve and made no diffence but tomorrow i'll take the selector apart.I'll have to make some phone calls to find the carb parts around here.This may take a few days to get Thanks again

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 GTX Revs stop at 6200 RPM
    By JohnLongest in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-18-2013, 08:01 PM
  2. 2002 polairs genesis loses power at full go but fine at 3/4
    By travis ingram in forum Polaris Open Discussion
    Replies: 0
    Last Post: 10-08-2012, 07:14 PM
  3. seadoo rxp max out at 6500 rpm with WOT
    By rxpsquad in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-20-2012, 10:21 AM
  4. 2003 Seadoo GTX SC REVS AT 6500 TO 6650 but top speed only 42 mph
    By gp1200nseadoogtx in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-02-2011, 09:25 PM
  5. 96 GTX Losing Power
    By houdinitattoo in forum 2-Stroke Performance
    Replies: 24
    Last Post: 05-18-2009, 08:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •