Results 1 to 8 of 8
  1. #1
    toolman11K's Avatar
    Join Date
    Jul 2008
    Location
    Big Lake, MN
    Posts
    52

    Arrow 2002 GTX OPAS issues?

    All,

    I just bought a 2002 SeaDoo GTX-4Tec to go along with my 2005 RXP. The problem is the ski is unstable at full throttle, and it does not seem to reach the top speed it should have. When I compare the OPAS paddles to the ones on my RXP they look like they stick down way to far. Reading the manual, these things are spring loaded, and they are supposed to raise as you get more speed. It feels to me like they are not doing that. Also it seems like when you are 45-50 the steering feels like it goes over center real easy, meaning if I try to run straight, it will allof a sudden go right, and needs a bit of left to correct. Also watching someone else run the ski, there is a ton of spray from the corners of the ski. This leads me to believe there is a issue with these things.
    The previous owner took it to the dealer the have a new impeller and wear ring installed, I am wondering if they put something on upside down?
    Does anyone know if these are supposed to look the same as the ones on the RXP?

    Thanks


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Cut a two pieces of 1" OD PVC pipe 2" long. The put a 1/4" slot lengthwise in each piece. Hold the OPAS paddle up and snap on the PVC. Do both sides. Take a ride and see if the helps. If it does, the OPAS screen, located in the 90 degree elbow on top of the jet pump may be blocked with crud from the last 8 years. So you can either clean the screen or leave the PVC pipes in place. BTW, IIRC the OPAS in the RXP does not move up & down like the GTX... Ron

  3. #3
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Also check #51 here:

    http://partsfinder.onlinemicrofiche....e=13&A=97&B=11

    I have seen plenty of these break and cause very erratic steering.

    But, I think KOF nailed it... you are describing classic "OPAS stuck downsyndrome".

  4. #4
    toolman11K's Avatar
    Join Date
    Jul 2008
    Location
    Big Lake, MN
    Posts
    52

    Thanks

    I know that #51 piece you are talking about, it is loose, but not broken, it seems like it could go in one of two ways, but is looks by the wear marks it is in the correct way.

    I will try the PVC and let you guys know.

    Thanks
    Koen

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Yeah it's $.50 worth of PVC if you DIY as compared tp $20 if you buy it already made... Ron

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Trying to get you post count up, huh? You might add some words (nouns and verbs) if you are trying to do that. If you need immediate medical assistance, post 911 a few times... Ron

  7. #7
    toolman11K's Avatar
    Join Date
    Jul 2008
    Location
    Big Lake, MN
    Posts
    52

    You guys rock

    Thanks,

    Just made 2 pieces, put them in and fixed. 55MPH and 7350 RPM and stable.

    Seems like that must be about right. It's no 70MPH RXP. but a nice ski for the wife.

    I din't check the hose & filter, I figured a mechanical override is a better fix anyway.

    Thanks again

  8. #8

    Join Date
    Jul 2006
    Location
    Hays, Kansas
    Posts
    150
    I noticed my steering being hard after taking a river ride. I took my PVC off and the paddles are stuck up and feel like they have sand in them causing hard steering. How do you clean them out? Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX OPAS issue
    By frogurt in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-20-2012, 12:26 AM
  2. 2002 GTX 4-tec 30mph issue.
    By Jasonsdad in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-28-2011, 07:52 PM
  3. 2002 gtx 4tec Check Engine problem.
    By kabab in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-28-2009, 03:30 AM
  4. 2002 GTX DI won't run above idle in water
    By zone 5 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-26-2007, 06:53 PM
  5. 2002 GTX DI MAintenece code?
    By Big Jay in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-10-2007, 08:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •