Results 1 to 6 of 6
  1. #1

    Bilge pump mounting help.....

    I am installing a bilge pump and I have a few questions. Can I mount it in the same location as the stock bilge pickup?? With the single pipe I know there is room but later if I decided to triple pipe is it still out of the way?? What/how do you guys mount it, with a bracket or are you glueing it to the hull surface??? One other question is there any secrets to removing the siphon tube from the pump nozzle? And are you guys grinding the surface flat where the water spout holes is drilled in the nozzle and filling it up???

    Im sorry I have so many questions!! But I looked in the nozzle today and I fiqured out why every one is removing the tube. It is way longer than I thought......

    thanks....


  2. #2
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Quote Originally Posted by OutlawGPR
    I am installing a bilge pump and I have a few questions. Can I mount it in the same location as the stock bilge pickup?? With the single pipe I know there is room but later if I decided to triple pipe is it still out of the way?? What/how do you guys mount it, with a bracket or are you glueing it to the hull surface??? One other question is there any secrets to removing the siphon tube from the pump nozzle? And are you guys grinding the surface flat where the water spout holes is drilled in the nozzle and filling it up???

    Im sorry I have so many questions!! But I looked in the nozzle today and I fiqured out why every one is removing the tube. It is way longer than I thought......

    thanks....

    Try to get the bilge pump as low as possible in the hull. I put my near the intermediate shaft. Clean the hull with acetone remove the bottom blue bracket, apply 5200 on the bottom of the blue bracket and let it sit overnight. You then can install the bilge pump and it wont come loose. If you install where the stock bilge is the #3 factory pipe will hit it when you go to tripples. You can apply some heat to the siphon tube and you should be able to tap it right out. On the sight spout just use a bolt and some jb weld and or get a hose and clamp it to the spout and plug the hose off.

  3. #3

    Bilge

    Thanks for the help. I was afraid that one of the pipes might interfere. I thought some where using 5200 to mount it. That makes it much easier....

  4. #4
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    Wat Con may have some mounting brackets left

  5. #5

    thanks

    Thanks for the help guys.

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    oops...I post'd the wrong link...

    here it is.... http://www.greenhulk.net/yama/showth...e+pump+bracket

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge Pump mounting & Electrics
    By Jumper in forum 4-Tec Performance
    Replies: 31
    Last Post: 07-10-2016, 01:01 PM
  2. Opinions Please - Bilge Pump Mounting
    By Badvgood in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 02-05-2013, 11:11 PM
  3. begi and bilge pump mounting
    By 05_RXP in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-24-2012, 12:19 PM
  4. bilge pump install help!
    By islandboy in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-01-2008, 08:16 AM
  5. Bilge pump runs all of the time HELP!
    By Rthomson in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-28-2007, 07:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •