Results 1 to 10 of 10
  1. #1
    toilets's Avatar
    Join Date
    Dec 2008
    Location
    Lake Norman NC
    Posts
    193

    problems yet again

    Afternoon folks, 2 questions if you dont mind... I know if you over fill your oil you lose rpm but what about if your oil is low? I only hit 7840 rpm today when i normally get 8140 all day long. I got a oil code on the guages and it cut the throttle, took it in and notice it was quite low, still between the two divits in the oil stick but definitely on the lower end near the first divit. Second I lost to a stock RXP racing today and was so pissed and didnt know why. After checking the oil I always check my ski and look it over and check the hull. The kicker is that I noticed that my worx grate was hanging down. One of the flipping bolts (center one of the three) actually snapped and caused it to break the plastic piece near the bolts. It looks like the entire piece that has the fins on it that goes to the prop is broke. Well that piece now snapped off near the grate. Questions are this. how much the this stupid pump inlet cost and also where could I be leaking oil? Actually do these crafts burn oil slightly? I checked where you add oil and I checked every where else and see no oil leak. Even the dealership said they didnt find a leak. Course every time I get out of the water and open my drain plugs I always see a milky white substance. Figured it was when my dealership changed the oil and there was some left over but that was over 30 hours ago. Any insight would be greatly appreciated. Ski has 56 hours. not even a year old and still under warranty. 07 rxp.


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Your speed and rpm issue is most likely the grate and pump shoe problem and it is probably leaking a little oil out around the drive shaft seal.

  3. #3
    toilets's Avatar
    Join Date
    Dec 2008
    Location
    Lake Norman NC
    Posts
    193
    Sweet dude thanks. I was hoping it was that and not a oil issue, or is leaking oil out of the shaft a concern? I got the oil changed at 13 hours and I now have 56. I can deal with that if its not a performance robbing issue...

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by toilets View Post
    Sweet dude thanks. I was hoping it was that and not a oil issue, or is leaking oil out of the shaft a concern? I got the oil changed at 13 hours and I now have 56. I can deal with that if its not a performance robbing issue...
    A small leak wont hurt anything as long as you keep your oil in the safety zone on the stick.

  5. #5
    toilets's Avatar
    Join Date
    Dec 2008
    Location
    Lake Norman NC
    Posts
    193
    Nice. You rock man. you have always been a big help to me on this forum! Thanks

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by toilets View Post
    Nice. You rock man. you have always been a big help to me on this forum! Thanks
    No problem. I'm glad I could help.

  7. #7
    With the trailer leveled / cold engine, my '06 RXP always runs best when I keep the Oil level just slightly above the lower crook on the dip stick. Never had the oil light come on, even in the rough stuff.

  8. #8
    toilets's Avatar
    Join Date
    Dec 2008
    Location
    Lake Norman NC
    Posts
    193
    Well crap.. Thats not good for me David. thats where it exactly is. (just above the rivit) and you said you never threw a oil indicator??? I was turning in flat smooth water when the code went on.

  9. #9
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by toilets View Post
    Well crap.. Thats not good for me David. thats where it exactly is. (just above the rivit) and you said you never threw a oil indicator??? I was turning in flat smooth water when the code went on.
    If I run mine that low it will code sometimes when turning hard or doing switch back turns.

    Here is the other part you will need to fix your grate issue. Its kinda a pain to swap and you will need a pump alignment tool also to do it. You will also want to either get one of speedfreaks girdles or upgrade you pump shoe and ride plate to 08 specs.
    #1 is the pump shoe.
    http://partsfinder.onlinemicrofiche....=13&A=149&B=14

  10. #10
    toilets's Avatar
    Join Date
    Dec 2008
    Location
    Lake Norman NC
    Posts
    193
    I will be racing my ski in stock class racing so im not sure if I can upgrade or not. I have a shop that does all my upgrades and repairs so I will have them take a look and repair it hopefully. I need someone to talk me into buying a rxp-x. Im just so afraid of the bucking issue since stock class boats are now seeing 76-78 mph. The GF is fed up with the ski but I keep telling her this is normal stuff. well the breaking of the grate isnt but other things are.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cam timing yet again
    By SHOBiz in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 08-03-2010, 05:54 PM
  2. Exxon, yet again, record PROFIT.
    By inothome in forum Open Discussion
    Replies: 51
    Last Post: 11-02-2008, 03:36 PM
  3. Flywheel Question, yet again
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 01-06-2008, 12:25 AM
  4. THANKS yet again RANDY!!!
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-10-2007, 12:05 AM
  5. Odd RXP Problem Happened Again????
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-19-2005, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •