Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267

    Changed CDI in 96 sltx 1050, now idles extremely high, please help!!!

    Hi, I am new register, even though i have looked up several other things before. I was wondering if anybody would know what could possibly be wrong. i blew out the CDI accidentally by connecting the battery late at night and hooked cables to the wrong posts. Before this happened the ski would start up and idle and purr like a kitten, because it has relatively low hours at 89 hours. I just received the new CDI and it is the most recent updated one for it. i was wondering if there was a learning curve for the new CDI or not? If anyone has any suggestions or knows what's wrong please help!!!! Thanks, Jason


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Welcome

    There is no learning curve in the CDI.

    Have you checked the simple things, like the throttle being stuck partially open?

    Have you double checked every wire and terminal that the CDI connects to - everyone is the correct color and location?

    What is the CDI part number?

    Do you know what magneto stator is in the engine - original or Ignition System Update Kit?

  3. #3
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267

    Smile

    Yes, i double checked every wire and they all match, the one i just installed is 4060180, and the one i took out was 4060137. I don't personally know a lot about 2 strokes, i used to be a four stroke guy all the way, but fell in love with this jetski as soon as i rode it, i loved it, and it is 9.5 out of 10 cosmetically and ran beautifully until I did a stupid thing and swapped batteries and just assumed that if the batteries were facing same way that the posts were the same. I'm not sure how to adjust the carbureter without screwing it up, unlesss someone can guide me throught it.

  4. #4
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267

    Smile

    also since the original cdi box was there I am assuming that the stator update kit wasn't done .

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Have a look in the service manual. It includes info on how to check and adjust the idle carb setting.

    Don't change anything yet, just check that the throttle plates are closing properly, and the throttle cable is not snagged or sticking.

    4060137 is indeed the original 1996 CDI

    4060180 is the CDI for the 1998-1999 three cylinder engines, but it is not the same as the 4010447 CDI that is in the Ignition Update Kit.

    I am not sure if the 4060180 CDI is compatible with the 1996-1997 4060128 magneto stator

    1998 engines came with the 4060175 stator.

  6. #6
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267

    Smile

    Sorry, I don't have a service manual for it. it didn't come with one. i ordered the part with one of the biggest dealers in the west @ Ride now powersports and they had the same info as Parker powersports also and said it was the correct one. But who knows? Dou you know where i can find a service manual for my ski? Also i was thinking of taking it to the lake to put a water load on it to se if it would help at all. Is that advisable and what could I hurt? Also by possibly changing the spark plugs, could that possibly help if the old ones in it know are fouled and causing it to run high rpm's? Thanks

  7. #7
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267

    Smile

    I'm going to temporarily log off, so I can update my computer. I will be back in a few for some more suggestions. Thanks

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Start by turning your idle screw down and then when you get it in the water adjust the idle as needed .
    it could be idling high just from sitting so long .
    How many rpm's is it idleing at now???
    yes that is the right cdi for the older stator it should be Fine

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Click Here>>>>>>>>service manual

  10. #10
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267
    Thanks everybody, it currently idles @ 2500 - 3000 rpm. I noticed if I pull the spark plug boot off off of midle cylinder it goes to normal idle, but if i pull it off front or back it stays the same. Could it be that I just have really bad plugs and they are fouling out. They looked kinda wet and black, so it least is rich enough. Thanks also for the free download of the service manual. Do I have to pull off the little plate below the spark arrrestor to adjust the idle screw? I can't hardly see anything it is so tight in there. I just don't want to mess with the wrong screw. I'll try to look at the service manual again, but i Didn't see a diagram for the carbs pointing pout the idle screw.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 sltx 1050 cdi box
    By dandydan003 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-18-2014, 09:22 AM
  2. 96 SLTX 1050 Rebuild
    By degg in forum Polaris Open Discussion
    Replies: 14
    Last Post: 10-02-2007, 11:33 AM
  3. 96 sltx 1050 rpm probs
    By fordnut78 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-03-2007, 07:47 PM
  4. 2006 STX 12F Idles too high. please help
    By Doutney1225 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 08-09-2007, 03:11 PM
  5. 2006 STX 12F Idles too high. please help
    By Doutney1225 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-09-2007, 11:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •